"Looks like you've followed a broken link" when viewing site

Hello Sir, I’m totally new to deployment.
I’m stuck at the same issue and not able to get over it. I’m trying to deploy my Vue App from GitHub repo: https://github.com/DaveSoham08/AllAboutCOVID
My Netlify App is: https://all-about-covid.netlify.app/

This shows Page Not Found error, although I’ve index.html on my main folder

@SD2000 Your dist publish directory has what appears to be static assets only, no index.html. One level up is where your index.html file is, but it appears to me that you are bypassing it.

Have you tried reading the documents?

Hey, Thank you I tried something and it worked even I don’t know how lol.
But thank you for your help

Hey, Sorry to disturb you again but due to some reason I had to discard my repo and site.
So Today I started from scratch and still I’m facing a similar issue.
This time my site is redirected but nothing is displayed on screen.
Console says “Failed to load resource: the server responded with a status of 404 ()”

repo: https://github.com/DaveSoham08/AllAboutCOVID19
Netlify app: https://all-about-covid19.netlify.app
Please help me out asap

Your page is loading, but you have a problem with your JavaScript: AOS.init(); cannot be found.

Thank you !!! :slight_smile:

Thank you for that. It solved the issue

Same problem with me.I am new to netlify.
Url:https://eloquent-elion-cd9bc3.netlify.app/
github:https://github.com/ajitkrsingh0786/ipl_data

@ajitkrsingh0786, have you checked out the support guide associated with this particular issue?

Yes I have already checked.But i din’t get any solution

Are you sure? Have you seen the very first line? :wink:

You have an index.js; we’ll look to serve index.html :+1:

My index.html file is inside public folder, whether we can’t put index.html file inide a folder?

You’ll need to set your public folder as your publish directory, and here’s why! :slight_smile:

Fine it’s working now.Very very thank you for support and assist.

1 Like