Deploy failing due to gem install error

Your Gemfile lists the gem activesupport (>= 0) more than once.
8:31:46 AM: You should probably keep only one of them.
8:31:46 AM: Remove any duplicate entries and specify the gem only once (per group).
8:31:46 AM: While it's not a problem now, it could cause errors if you change the version of one of them later.
8:31:46 AM: Could not load OpenSSL.
8:31:46 AM: You must recompile Ruby with OpenSSL support or change the sources in your
8:31:47 AM: failed during stage 'building site': Build script returned non-zero exit code: 1
8:31:46 AM: Gemfile from 'https' to 'http'. Instructions for compiling with OpenSSL using
8:31:46 AM: RVM are available at http://rvm.io/packages/openssl.
8:31:46 AM: Error during gem install
8:31:46 AM: Error running command: Build script returned non-zero exit code: 1
8:31:46 AM: Failing build: Failed to build site

Haven’t really changed anything of significance, so I suspect this is due to something at Netlify’s end. Netlify, please help?

Hi, @shreyas-satish, and welcome to our Netlify community site. This might be because the version of Ruby being used by Netlify differs from your local install.

If this is the case, you can set the version in the Netlify build system by setting the environment variable RUBY_VERSION in the site settings.

There is more documentation about this here:

https://docs.netlify.com/configure-builds/environment-variables/#netlify-configuration-variables

If that doesn’t resolve the issue (or there are other questions about this), please let us know.

1 Like

Thanks Luke! Setting RUBY_VERSION to my local version fixed it.