"Your connection is not private" - Google Chrome security error

Hi all, setting up my Netlify website for my client, who is not a happy camper at the moment. The sooner this gets resolved the better for me.

My problem…
https://livingwisely.org/ works fine!
https://www.livingwisely.org/ gets a security error!

Two questions - why the error? What can I do to resolve it? Open to redirects, updating DNS, whatever…

Many thx!

Hi @makeitrein !

This is a pretty frequent problem as mentioned in this article: [Common Issue] Are there rate limits when provisioning SSL/TLS certificates using Netlify?

In effect, we can make a partial certificate for you if your DNS is only partly propagated when you configure hostnames in our system, and the “fix” is to hit the “renew certificate” button in our UI, at the bottom of the Domain Settings page as shown in this screenshot:

In this case, I went ahead and renewed it for you, but for others who have this problem, you can self-solve (though DNS does need to be correctly configured and propagated first!).

2 Likes

@fool

My site was deployed and was waiting on DNS propagation for the SSL certification. I checked back a bit later and my site is now https enabled. I get the same warning from Chrome and when i click “Renew certificate” I get “mydomain.com doesn’t appear to be served by Netlify” even though I have added the nameservers to the domain. I would suggest Netlify not install certificates until everything is fully propagated so the user can indeed “Renew certificate”.

There’s no way to go back to just HTTP so i don’t know what to do here except hit “Renew certificate” throughout the day and hope(??)

UPDATE: I was able to “Renew certificate” but the warning persists. I’m afraid to keep renewing in fear of hitting the let’s encrypt request limit.

FINAL UPDATE: I guess it was a dns propagation thing. Checked my site after a few hours after clicking the Renew Certificate button and everything was good to go. No more browser warning.

1 Like