Where did my sites go? I can't see them in Netlify even though they are deployed!

Briefly summarize the issues you have been experiencing.

Please provide a link to your live site hosted on Netlify

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?

Hi all- I’ve got a few “toy projects” that I deployed to Netlify (via GitHub) at various points in the last couple months. The sites seem to be functioning fine–but when I go to the “sites” tab of my user page, the sites simply aren’t there…the list is just empty.

Am I simply being stupid here? Assuming I’m not, is there any way I can view those sites (for example, to see a deployment history or (assuming I wanted to) delete one of them?) Does the fact that the sites are deployed via GitHub have anything to do with it?

Please advise.

G.

@giacomo_bucket I would send a support email using https://netlify.com/support , that does not sound right. Someone in support needs to check it for you.

1 Like

Hi @giacomo_bucket - I have experienced this before, actually - when I was deploying some starter repos for example to play around with some static site generators. The sites were live, but when I logged into Netlify.com I couldn’t see them. It was very odd.

Then I realized that due to being logged in via SSO/github, the new sites were actually being created under a different email with Netlify than I had originally set up manually. (To be really clear - I actually had two netlify accounts as my github email is a different one than my manually created Netlify account).

Can you confirm that you’re not experiencing the same situation I am describing above? This would definitely explain why you have “ghost” sites.

Hi Perry- Thanks for responding. What you describe could definitely be a possibility. I don’t have time to check it out at the moment, but I’ll try and investigate later today or tomorrow.

G

1 Like

Two other possibilities for folks who end up here (I don’t think this happened to Giacomo), just for the sake of completeness:

  1. Your “old” account got marked as spam (presumably incorrectly, if you are asking about it as though you didn’t realize that hosting malware is against our ToS :wink: ) by our spam-fighting robots, and in that case you’ll need our help to resurrect the sites but they are not lost in that case.
  2. our email logins are CASE SENSITIVE so bob@gmail.com and Bob@gmail.com may be the same login at google - but they are separate at Netlify.