Very slow TTFB on two netlify sites

Hi,

My website is also getting very slow TTFB:

inkdrop.app is aliased to inkdrop-top.netlify.com.

Could you advise me how to improve it?

Maybe I guess that’s because I’m using ALIAS record for my apex domain with NS1. As its documentation says:

Disadvantages of an ALIAS record

  • Geo-targeting information is lost.
    Since it is the authoritative server for example.com (issuing the queries for lb.example.net), then any intelligent routing functionality on the lb.example.net record will act upon the location of the authoritative server instead of your location. The EDNS0 edns-client-subnet option does not apply here. This means that you may be potentially mis-routed. For example, if you are in New York and the authoritative server for example.com is in California, then lb.example.net will think you are in California, and will return an answer that is distinctly sub-optimal for you in New York.

So, I guess Netlify CDN doesn’t optimize based on user’s location?

we rolled out a fix to issues raised in your original thread, so we are thinking your problem might be something else so I made a new thread where we can discuss. That said could you take a look at this and provide us with a HAR file so we can take a closer look?

To answer your question @craftzdog our CDN does optimize based on location, but you cannot use an “ALIAS” record from NS1 since that explicitly does not trigger our geo-location features. You’ll need to use one of two things, at present:

  1. our DNS hosting, since we can (and do) use linked A records which do allow geolocation
  2. Cloudflare’s CNAME flattening, since that does not seem to interfere with our geolocation

Seems like maybe you already use NS1 with your own account, which we may be able to additionally help with - I have a question out to our team. But for the meantime, please test TTFB for your CNAME from a subdomain since those do allow geolocation and let us know if it still seems slow.

OK, after some discussion with our platform team, since you do use NS1, you could try using a linked A record (cf https://ns1.com/blog/announcing-linked-records), pointing to yoursitename.netlify.com (in your case, inkdrop-top.netlify.com ). NS1’s support team reports that they should work across accounts, but I have not had a chance to test it out yet. Might be best to try a third hostname like yourtest.inkdrop.app to see how performance feels via that URL (you’ll have to enter it in domain settings here: https://app.netlify.com/sites/inkdrop-top/settings/domain#custom-domains , and set up DNS first, of course). Let me know how it goes no matter which method you choose!

Hi fool,

Thanks for the clarification.
As CNAME performs as fast as expected, just moving from apex to www subdomain would be a good option.

NS1’s linked record sounds great, and I tried it but it seems like not working.
I configured the record on NS1 like so:

and added a domain alias on Netlify.
But Netlify doesn’t recognize the DNS record and always says “Check DNS configuration”, even after 1 hour:

host -v top-test.inkdrop.app
Trying "top-test.inkdrop.app"
Host top-test.inkdrop.app not found: 2(SERVFAIL)
Received 38 bytes from 172.20.10.1#53 in 42 ms

It responds SERVFAIL.

OK. Could you try instead linking to “www.bitballoon.com” to see if that works better? I very much appreciate your help in testing.

Thanks for the help.
But it won’t work. It still responds with SERVFAIL. My configuration is:

Hmm, ok. I guess there isn’t a good way to accomplish this right now. Sorry I don’t have better news for you!

Our operations team did some tests and found this to work. Is worth a try before we give up!

Could you try linking (with a linked A record) directly to *.netlify.app (it’s a weird-sounding config, but that is a “real record” in our account) on that hostname and see if it works better? If it doesn’t, we should be able to work with NS1’s support to figure out why it worked well from our (separate) test account and not from yours.