Very slow (*static* page takes more than one minute to load)

Hello,

It takes more than one minute for any webpage of my (small) website to load today. Does anyone have the same issue ? What can I do ?

Thanks !

Hi Frederic and welcome to our community!

That isn’t normal, so we’ll be happy to investigate. Could you give us the URL of the site that is slow? It would also be useful to find the single slowest request that Netlify is involved in, and send us the value of the x-nf-request-id HTTP response header as described here: [Common Issue] Netlify Support asked for the 'x-nf-request-id' header? Why are they asking for it and how do I find it? so we can help troubleshoot.

Hello I will send you x-nf-request-id header when new issue will happen. Thanks for your support

2 Likes

Hi I am also getting slow speeds when the website loads and changing pages

Please provide that x-nf-request-id http response header that I asked Frederic for, @coreybruce - that’s what we need to debug.

Sure thing
x-nf-request-id: 9f3bed78-86fb-4ab9-80cd-7b80f4b33adf-28590644

Everything seems to running fast, thanks for the help!

I don’t think we did anything, so no thanks are necessary.

The x-nf-request-id you sent took us 261 milliseconds to serve according to our logs - not what I’d call slow to serve. However I do see a handful that took 6 seconds to that domain, which is absolutely super slow. Those are related to the issue in this thread which as you’ve experienced is rather intermittent:

We’ll follow up there once we get a fix out.

Hi everyone, we have some great news :tada:

We have tested & rolled out a fix for these issues.

More information here:

Please feel free to discuss on that thread, I will close this one (and others) so to contain the conversation a bit more. Thank you all for your patience :pray: