Undesired redirection from .com to .app domain

Hello,
Since this afternoon (france), on my application, the netlify.com domain is automatically redirected to netlify.app domain. It causes an invalid redirect uri with my google OAuth system. Why netlify has changed the default .com domain ?
Thanks

Hi there.

Details on the change (why, how, etc) are here:

I think we fixed the Oauth problems for folks using our own OAuth settings (in our admin UI, on the “access control” panel) about 30 minutes ago - is that what you are using, and have you tried again in the past half hour or so?

Thank you for your answer.
No i am not using netlify OAuth provider system. i’ve implemented my own system with google sign in api, so i have to declare authorized redirect uri(s) to google api.
So i understand that i must re-declare my service to google api. is that true ?

I couldn’t say; I don’t use that product and we can’t offer tech support on it. Their tech support will have to help you out on that one!

my last question was to ensure myself that netlify don’t have a workaround for this problem.
it was a rethoric question too, to point these facts :
1 - i did not receive any information before this big change, so i was not able to anticipate.
2 - you say :

Will my current sites continue to work?
Absolutely. Any sites already deployed to site-name.netlify.com will continue to operate, just as they do now.

It is not true for some (and i am sure a lot of) sites.

sorry for spamming…
it also causes netlify function crash…because uri has changed and calls can’t fetch a redirect response…

1 Like

Yes, Sorry, we didn’t say because we thought it was obvious: how third parties use our service could change. Your netlify site will keep working in web browsers, is what we were trying to communicate. Sorry this caused problems for you, but we did give you quite a lot of heads up to get changes planned and staged, and that was the best we could do at the scale we had to work with.

Whatever you have calling a function will hopefully follow the 301 redirect, if not, I guess yes, you do need to update the callers to call .app directly.

@antonypittman what i’ve understood is you can’t. you have to re-declare the correct uri in your google developper console and modify your key with the newest provided by google in your auth system

and redeploy by the way…

There is no way for you to disable it. What problems are you having in more detail, so we can try to address, @antonypittman?

We were hoping you would have said something in the 60 days since we announced it, Anant, if you had concerns. We also would have been happy to advise you in migrating at any point in the last 2 weeks when the new site hostnames were already working.

At any rate, if you intend to cancel your service as a result of this change, let me know and I can see about providing you a refund for your last payment so you can apply that money to a new service.