Unable to deploy website unsure whats going on

  • the netlify site name is unruffled-thompson-be09c7`
    I am trying to deploy a site using react and tailwind here is the errors I am getting.

6:06:13 PM: Build ready to start
6:06:15 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
6:06:15 PM: build-image tag: v3.4.1
6:06:15 PM: buildbot version: fcbc7a79f7372e5995cf02954ef19fc48d20c871
6:06:16 PM: Fetching cached dependencies
6:06:16 PM: Failed to fetch cache, continuing with build
6:06:16 PM: Starting to prepare the repo for build
6:06:16 PM: No cached dependencies found. Cloning fresh repo
6:06:16 PM: git clone https://github.com/RaymondLi-1993/React-tv
6:06:17 PM: Preparing Git Reference refs/heads/master
6:06:18 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: β€˜build’ versus β€˜build/’ in the Netlify UI
6:06:18 PM: Starting build script
6:06:18 PM: Installing dependencies
6:06:18 PM: Python version set to 2.7
6:06:19 PM: v12.18.0 is already installed.
6:06:20 PM: Now using node v12.18.0 (npm v6.14.4)
6:06:20 PM: Started restoring cached build plugins
6:06:20 PM: Finished restoring cached build plugins
6:06:20 PM: Attempting ruby version 2.7.1, read from environment
6:06:22 PM: Using ruby version 2.7.1
6:06:22 PM: Using PHP version 5.6
6:06:22 PM: 5.2 is already installed.
6:06:22 PM: Using Swift version 5.2
6:06:22 PM: Started restoring cached node modules
6:06:22 PM: Finished restoring cached node modules
6:06:23 PM: Installing NPM modules using NPM version 6.14.4
6:06:52 PM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/babel-runtime/node_modules/core-js
6:06:52 PM: > node -e β€œtry{require(’./postinstall’)}catch(e){}”
6:06:52 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/core-js
6:06:52 PM: > node -e β€œtry{require(’./postinstall’)}catch(e){}”
6:06:52 PM: > core-js-pure@3.6.5 postinstall /opt/build/repo/node_modules/core-js-pure
6:06:52 PM: > node -e β€œtry{require(’./postinstall’)}catch(e){}”
6:06:54 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
6:06:54 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:06:54 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchpack-chokidar2/node_modules/fsevents):
6:06:54 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:06:54 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/jest-haste-map/node_modules/fsevents):
6:06:54 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:06:54 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):
6:06:54 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:06:54 PM: added 1693 packages from 796 contributors and audited 1701 packages in 30.838s
6:06:56 PM: 67 packages are looking for funding
6:06:56 PM: run npm fund for details
6:06:56 PM: found 0 vulnerabilities
6:06:56 PM: NPM modules installed
6:06:56 PM: Started restoring cached go cache
6:06:56 PM: Finished restoring cached go cache
6:06:56 PM: go version go1.14.4 linux/amd64
6:06:56 PM: go version go1.14.4 linux/amd64
6:06:56 PM: Installing missing commands
6:06:56 PM: Verify run directory
6:06:57 PM: ​
6:06:57 PM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
6:06:57 PM: β”‚ Netlify Build β”‚
6:06:57 PM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
6:06:57 PM: ​
6:06:57 PM: ❯ Version
6:06:57 PM: @netlify/build 3.3.0
6:06:57 PM: ​
6:06:57 PM: ❯ Flags
6:06:57 PM: deployId: 5f48588524ed64008bac5f0a
6:06:57 PM: mode: buildbot
6:06:57 PM: ​
6:06:57 PM: ❯ Current directory
6:06:57 PM: /opt/build/repo
6:06:57 PM: ​
6:06:57 PM: ❯ Config file
6:06:57 PM: No config file was defined: using default values.
6:06:57 PM: ​
6:06:57 PM: ❯ Context
6:06:57 PM: production
6:06:57 PM: ​
6:06:57 PM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
6:06:57 PM: β”‚ 1. Build command from Netlify app β”‚
6:06:57 PM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
6:06:57 PM: ​
6:06:57 PM: $ CI= npm run build
6:06:58 PM: > tailwind-tv@0.1.0 build /opt/build/repo
6:06:58 PM: > npm run build:css && react-scripts build
6:06:58 PM: > tailwind-tv@0.1.0 build:css /opt/build/repo
6:06:58 PM: > postcss src/Assests/tailwind.css -o src/Assests/main.css
6:07:03 PM: Creating an optimized production build…
6:07:08 PM: Failed to compile.
6:07:08 PM:
6:07:08 PM: ./src/App.js
6:07:08 PM: Cannot find module: β€˜react-router-dom’. Make sure this package is installed.
6:07:08 PM: You can install this package by running: npm install react-router-dom.
6:07:08 PM: npm ERR! code ELIFECYCLE
6:07:08 PM: npm ERR! errno 1
6:07:08 PM: npm ERR! tailwind-tv@0.1.0 build: npm run build:css && react-scripts build
6:07:08 PM: npm ERR! Exit status 1
6:07:08 PM: npm ERR!
6:07:08 PM: npm ERR! Failed at the tailwind-tv@0.1.0 build script.
6:07:08 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
6:07:09 PM: npm ERR! A complete log of this run can be found in:
6:07:09 PM: npm ERR! /opt/buildhome/.npm/_logs/2020-08-28T01_07_08_998Z-debug.log
6:07:09 PM: ​
6:07:09 PM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
6:07:09 PM: β”‚ β€œbuild.command” failed β”‚
6:07:09 PM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
6:07:09 PM: ​
6:07:09 PM: Error message
6:07:09 PM: Command failed with exit code 1: CI= npm run build
6:07:09 PM: ​
6:07:09 PM: Error location
6:07:09 PM: In Build command from Netlify app:
6:07:09 PM: CI= npm run build
6:07:09 PM: ​
6:07:09 PM: Resolved config
6:07:09 PM: build:
6:07:09 PM: command: CI= npm run build
6:07:09 PM: commandOrigin: ui
6:07:09 PM: publish: /opt/build/repo/build
6:07:09 PM: Caching artifacts
6:07:09 PM: Started saving node modules
6:07:09 PM: Finished saving node modules
6:07:09 PM: Started saving build plugins
6:07:09 PM: Finished saving build plugins
6:07:09 PM: Started saving pip cache
6:07:09 PM: Finished saving pip cache
6:07:09 PM: Started saving emacs cask dependencies
6:07:09 PM: Finished saving emacs cask dependencies
6:07:09 PM: Started saving maven dependencies
6:07:09 PM: Finished saving maven dependencies
6:07:09 PM: Started saving boot dependencies
6:07:09 PM: Finished saving boot dependencies
6:07:09 PM: Started saving go dependencies
6:07:09 PM: Finished saving go dependencies
6:07:11 PM: Error running command: Build script returned non-zero exit code: 1
6:07:11 PM: Failing build: Failed to build site
6:07:11 PM: Failed during stage β€˜building site’: Build script returned non-zero exit code: 1
6:07:12 PM: Finished processing build request in 56.352645246s

Here is also a picture of how the build is on my vs code.

Thanks!

hey there, seems like you don’t have this package that you need listed out in your package.json file? or if you added it, did you push the most up-to-date version of your package.json?

I reinstalled the react-router-dom, and updated the build but it still seems like im getting the same errors.

6:44:47 PM: Waiting for other deploys from your team to complete
6:47:01 PM: Build ready to start
6:47:06 PM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6
6:47:06 PM: build-image tag: v3.4.1
6:47:06 PM: buildbot version: fcbc7a79f7372e5995cf02954ef19fc48d20c871
6:47:07 PM: Fetching cached dependencies
6:47:07 PM: Failed to fetch cache, continuing with build
6:47:07 PM: Starting to prepare the repo for build
6:47:07 PM: No cached dependencies found. Cloning fresh repo
6:47:07 PM: git clone https://github.com/RaymondLi-1993/React-tv
6:47:08 PM: Preparing Git Reference refs/heads/master
6:47:09 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: β€˜build’ versus β€˜build/’ in the Netlify UI
6:47:09 PM: Starting build script
6:47:09 PM: Installing dependencies
6:47:09 PM: Python version set to 2.7
6:47:10 PM: v12.18.0 is already installed.
6:47:11 PM: Now using node v12.18.0 (npm v6.14.4)
6:47:11 PM: Started restoring cached build plugins
6:47:11 PM: Finished restoring cached build plugins
6:47:11 PM: Attempting ruby version 2.7.1, read from environment
6:47:13 PM: Using ruby version 2.7.1
6:47:13 PM: Using PHP version 5.6
6:47:13 PM: 5.2 is already installed.
6:47:13 PM: Using Swift version 5.2
6:47:13 PM: Started restoring cached node modules
6:47:13 PM: Finished restoring cached node modules
6:47:13 PM: Installing NPM modules using NPM version 6.14.4
6:47:45 PM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/babel-runtime/node_modules/core-js
6:47:45 PM: > node -e β€œtry{require(’./postinstall’)}catch(e){}”
6:47:45 PM: > core-js@3.6.5 postinstall /opt/build/repo/node_modules/core-js
6:47:45 PM: > node -e β€œtry{require(’./postinstall’)}catch(e){}”
6:47:46 PM: > core-js-pure@3.6.5 postinstall /opt/build/repo/node_modules/core-js-pure
6:47:46 PM: > node -e β€œtry{require(’./postinstall’)}catch(e){}”
6:47:48 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
6:47:48 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:47:48 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchpack-chokidar2/node_modules/fsevents):
6:47:48 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:47:48 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/jest-haste-map/node_modules/fsevents):
6:47:48 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:47:48 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/fsevents):
6:47:48 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {β€œos”:β€œdarwin”,β€œarch”:β€œany”} (current: {β€œos”:β€œlinux”,β€œarch”:β€œx64”})
6:47:48 PM: added 1704 packages from 801 contributors and audited 1712 packages in 34.033s
6:47:50 PM: 67 packages are looking for funding
6:47:50 PM: run npm fund for details
6:47:50 PM: found 0 vulnerabilities
6:47:50 PM: NPM modules installed
6:47:50 PM: Started restoring cached go cache
6:47:50 PM: Finished restoring cached go cache
6:47:50 PM: go version go1.14.4 linux/amd64
6:47:50 PM: go version go1.14.4 linux/amd64
6:47:50 PM: Installing missing commands
6:47:50 PM: Verify run directory
6:47:51 PM: ​
6:47:51 PM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
6:47:52 PM: β”‚ Netlify Build β”‚
6:47:52 PM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
6:47:52 PM: ​
6:47:52 PM: ❯ Version
6:47:52 PM: @netlify/build 3.3.0
6:47:52 PM: ​
6:47:52 PM: ❯ Flags
6:47:52 PM: deployId: 5f48618fed9dd10007542bd8
6:47:52 PM: mode: buildbot
6:47:52 PM: ​
6:47:52 PM: ❯ Current directory
6:47:52 PM: /opt/build/repo
6:47:52 PM: ​
6:47:52 PM: ❯ Config file
6:47:52 PM: No config file was defined: using default values.
6:47:52 PM: ​
6:47:52 PM: ❯ Context
6:47:52 PM: production
6:47:52 PM: ​
6:47:52 PM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
6:47:52 PM: β”‚ 1. Build command from Netlify app β”‚
6:47:52 PM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
6:47:52 PM: ​
6:47:52 PM: $ npm run build
6:47:52 PM: > tailwind-tv@0.1.0 build /opt/build/repo
6:47:52 PM: > npm run build:css && react-scripts build
6:47:52 PM: > tailwind-tv@0.1.0 build:css /opt/build/repo
6:47:52 PM: > postcss src/Assests/tailwind.css -o src/Assests/main.css
6:47:58 PM: Creating an optimized production build…
6:48:06 PM: Failed to compile.
6:48:06 PM:
6:48:06 PM: ./src/components/info.jsx
6:48:06 PM: Cannot find module: β€˜axios’. Make sure this package is installed.
6:48:06 PM: You can install this package by running: npm install axios.
6:48:06 PM: npm ERR! code ELIFECYCLE
6:48:06 PM: npm ERR! errno 1
6:48:06 PM: npm ERR! tailwind-tv@0.1.0 build: npm run build:css && react-scripts build
6:48:06 PM: npm ERR! Exit status 1
6:48:06 PM: npm ERR!
6:48:06 PM: npm ERR! Failed at the tailwind-tv@0.1.0 build script.
6:48:06 PM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
6:48:06 PM: npm ERR! A complete log of this run can be found in:
6:48:06 PM: npm ERR! /opt/buildhome/.npm/_logs/2020-08-28T01_48_06_365Z-debug.log
6:48:06 PM: ​
6:48:06 PM: β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
6:48:06 PM: β”‚ β€œbuild.command” failed β”‚
6:48:06 PM: β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
6:48:06 PM: ​
6:48:06 PM: Error message
6:48:06 PM: Command failed with exit code 1: npm run build
6:48:06 PM: ​
6:48:06 PM: Error location
6:48:06 PM: In Build command from Netlify app:
6:48:06 PM: npm run build
6:48:06 PM: ​
6:48:06 PM: Resolved config
6:48:06 PM: build:
6:48:06 PM: command: npm run build
6:48:06 PM: commandOrigin: ui
6:48:06 PM: publish: /opt/build/repo/build
6:48:06 PM: Caching artifacts
6:48:06 PM: Started saving node modules
6:48:06 PM: Finished saving node modules
6:48:06 PM: Started saving build plugins
6:48:06 PM: Finished saving build plugins
6:48:06 PM: Started saving pip cache
6:48:06 PM: Finished saving pip cache
6:48:06 PM: Started saving emacs cask dependencies
6:48:06 PM: Finished saving emacs cask dependencies
6:48:06 PM: Started saving maven dependencies
6:48:06 PM: Finished saving maven dependencies
6:48:06 PM: Started saving boot dependencies
6:48:06 PM: Finished saving boot dependencies
6:48:06 PM: Started saving go dependencies
6:48:06 PM: Finished saving go dependencies
6:48:09 PM: Error running command: Build script returned non-zero exit code: 1
6:48:09 PM: Failing build: Failed to build site
6:48:09 PM: Failed during stage β€˜building site’: Build script returned non-zero exit code: 1
6:48:09 PM: Finished processing build request in 1m2.462315487s

It is deployed! it seems like I had to re install react-router-dom and axios, however, only my header is showing up in my app. Does it have anything to do with the tailwind build error?

Screen Shot 2020-08-27 at 6.55.55 PM|690x431

solved! Thank you so much for helping me out! Much appreciated!

1 Like

glad we got it fixed so fast! welcome to netlify :smiley: