Unable to deploy node.js/ejs stuck on building

build command was

node ./app.js

Deploys for serene-kilby-1b9ab0

the deploy is stuck on building if i run this on my pc website works on local host

hi, can you post your full build log please?

1:10:32 AM: Build ready to start
1:10:34 AM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
1:10:34 AM: build-image tag: v3.3.20
1:10:34 AM: buildbot version: be8ecf2af866e16fa4301cc5c14de2ccbbb21cf4
1:10:34 AM: Fetching cached dependencies
1:10:35 AM: Starting to download cache of 73.3MB
1:10:35 AM: Finished downloading cache in 433.843146ms
1:10:35 AM: Starting to extract cache
1:10:37 AM: Finished extracting cache in 2.525199903s
1:10:37 AM: Finished fetching cache in 2.98416991s
1:10:37 AM: Starting to prepare the repo for build
1:10:38 AM: Preparing Git Reference refs/heads/master
1:10:39 AM: Different build command detected, going to use the one specified in the Netlify configuration file: 'npm install && nohup node ./app.js' versus 'node ./app.js &' in the Netlify UI
1:10:39 AM: Starting build script
1:10:39 AM: Installing dependencies
1:10:39 AM: Python version set to 2.7
1:10:40 AM: Started restoring cached node version
1:10:42 AM: Finished restoring cached node version
1:10:43 AM: v12.18.0 is already installed.
1:10:43 AM: Now using node v12.18.0 (npm v6.14.4)
1:10:43 AM: Started restoring cached build plugins
1:10:43 AM: Finished restoring cached build plugins
1:10:43 AM: Attempting ruby version 2.7.1, read from environment
1:10:45 AM: Using ruby version 2.7.1
1:10:45 AM: Using PHP version 5.6
1:10:45 AM: 5.2 is already installed.
1:10:45 AM: Using Swift version 5.2
1:10:45 AM: Started restoring cached node modules
1:10:45 AM: Finished restoring cached node modules
1:10:45 AM: Started restoring cached go cache
1:10:45 AM: Finished restoring cached go cache
1:10:45 AM: go version go1.14.4 linux/amd64
1:10:45 AM: go version go1.14.4 linux/amd64
1:10:45 AM: Installing missing commands
1:10:45 AM: Verify run directory
1:10:46 AM: ​
1:10:46 AM: ┌─────────────────────────────┐
1:10:46 AM: │        Netlify Build        │
1:10:46 AM: └─────────────────────────────┘
1:10:46 AM: ​
1:10:46 AM: ❯ Version
1:10:46 AM:   @netlify/build 3.0.1
1:10:46 AM: ​
1:10:46 AM: ❯ Flags
1:10:46 AM:   deployId: 5f2473b0e109a0000848bb05
1:10:46 AM:   mode: buildbot
1:10:46 AM: ​
1:10:46 AM: ❯ Current directory
1:10:46 AM:   /opt/build/repo
1:10:46 AM: ​
1:10:46 AM: ❯ Config file
1:10:46 AM:   /opt/build/repo/netlify.toml
1:10:46 AM: ​
1:10:46 AM: ❯ Context
1:10:46 AM:   production
1:10:46 AM: ​
1:10:46 AM: ┌────────────────────────────────────┐
1:10:46 AM: │ 1. build.command from netlify.toml │
1:10:46 AM: └────────────────────────────────────┘
1:10:46 AM: ​
1:10:46 AM: $ npm install && nohup node ./app.js
1:10:48 AM: audited 57 packages in 0.743s
1:10:48 AM: found 0 vulnerabilities
1:10:48 AM: ​
1:10:48 AM: (build.command completed in 1.5s)
1:10:48 AM: ​
1:10:48 AM: ┌─────────────────────────────┐
1:10:48 AM: │   Netlify Build Complete    │
1:10:48 AM: └─────────────────────────────┘
1:10:48 AM: ​
1:10:48 AM: (Netlify Build completed in 1.5s)
1:10:48 AM: Caching artifacts
1:10:48 AM: Started saving node modules
1:10:48 AM: Finished saving node modules
1:10:48 AM: Started saving build plugins
1:10:48 AM: Finished saving build plugins
1:10:48 AM: Started saving pip cache
1:10:48 AM: Finished saving pip cache
1:10:48 AM: Started saving emacs cask dependencies
1:10:48 AM: Finished saving emacs cask dependencies
1:10:48 AM: Started saving maven dependencies
1:10:48 AM: Finished saving maven dependencies
1:10:48 AM: Started saving boot dependencies
1:10:48 AM: Finished saving boot dependencies
1:10:48 AM: Started saving go dependencies
1:10:48 AM: Finished saving go dependencies
1:10:48 AM: Build script success
1:10:48 AM: Starting to deploy site from 'public'
1:10:48 AM: Creating deploy tree 
1:10:48 AM: Creating deploy upload records
1:10:48 AM: 1 new files to upload
1:10:48 AM: 0 new functions to upload
1:10:49 AM: Starting post processing
1:10:49 AM: Post processing - HTML
1:10:49 AM: Post processing - redirect rules
1:10:49 AM: Post processing - header rules
1:10:49 AM: Post processing done
1:10:49 AM: Site is live
1:11:00 AM: Finished processing build request in 25.517819447s

hey there, maybe i am misunderstanding but it seems like we are able to build and deploy your site just fine? :thinking:

it be exact its completing its building but its not showing anything in link https://serene-kilby-1b9ab0.netlify.app/
see its not showing anything even if the site is alive ?

if i go to my page i see this

Page Not Found

Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.

even after the site is build ??
link serene-kilby-1b9ab0 . netlify . app

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in this guide, please let us know!