Trying to understand why my site isn't working

Briefly summarize the issues you have been experiencing.
I’m trying to figure out why my deployment isn’t working


not getting any errors on the deployment itself.
It’s a standard Angular App

build command is npm run build
Publish directory is dist

Please provide a link to your live site hosted on Netlify
https://ng7.sourcecodesamurai.com/

What have you tried as far as troubleshooting goes? Do you have an idea what is causing the problem?

tried changing build command to ng build and the publish directory to dist/ so far no joy.

Do you have any other information that is relevant, such as links to docs, libraries, or other resources?

When you run your build command on your local system, are there files in your dist directory?

The final messages shows there are 0 files to upload, so nothing gets deployed.

10:59:39 AM: Creating deploy tree 
10:59:39 AM: 0 new files to upload
10:59:40 AM: Site is live
10:59:39 AM: 0 new functions to upload
11:00:27 AM: Finished processing build request in 1m45.553124322s
1 Like

yes in my dist directory is a directory called ng7-complete-course and in it is all my app files.

I have to be doing something (or not doing something) stupid. But whatever it is I’ve now done it twice I have another project that I can’t get deployed on Netlify. These are not my first Netlify projects but so far I can’t tell any difference (other than perhaps version of angular) between my app that works and the two that don’t.

Hi @carl-parrish, what do you have the publish directory set to on the site or in your netlify.toml?

@futuregerald Is this what you mean?

Hey Carl, we’ll respond to you via e-mail on this one so you don’t have to share any private info!