Swiper.css dependency: ERR_ABORTED 404

Hey guys!

Just trying to get familiar with your site but it seems that my swiper dependency isn’t getting built properly. I get this reponse:

reframeldsp.netlify.com/:6 GET https://reframeldsp.netlify.com/node_modules/swiper/css/swiper.min.css net::ERR_ABORTED 404
reframeldsp.netlify.com/:594 GET https://reframeldsp.netlify.com/node_modules/swiper/js/swiper.min.js

here is my package.json:

{
“name”: “reframe”,
“version”: “1.0.0”,
“description”: “Reframe main website”,
“main”: “main.js”,
“dependencies”: {
“serve”: “^11.3.0”,
“swiper”: “^5.3.0”
},
“devDependencies”: {},
“scripts”: {
“test”: “echo “Error: no test specified” && exit 1”,
“start”: “node main.js”
},
“repository”: {
“type”: “git”,
“url”: “git+https://github.com/verrixkio/Reframe-2020.git”
},
“author”: “”,
“license”: “ISC”,
“bugs”: {
“url”: “https://github.com/verrixkio/Reframe-2020/issues
},
“homepage”: “https://github.com/verrixkio/Reframe-2020#readme
}

I checked the docs but it looks like you guys do npm install for dependencies so not quite sure why its not working.

Let me know how i can fix this :slight_smile:
Thanks

can you verify that this is working locally?

If you do a fresh clone from the git repo can you do an npm install without any problems?

That would be the first recommended sanity check to verify that the issue isn’t coming from somewhere else :wink:

If the issue still persists, can you post your full build log or link us to your most recent one?