Subdomain SSL for branch deploy

Hi all,

I’ve recently setup DNS for beta.jloh.co pointing to beta-jloh.netlify.app. If the SSL cert/internal routing could be changed so this branch works for that domain it’d be great! See below dig for proof:

$ dig beta.jloh.co

; <<>> DiG 9.10.6 <<>> beta.jloh.co
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33747
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;beta.jloh.co.			IN	A

;; ANSWER SECTION:
beta.jloh.co.		3593	IN	CNAME	beta-jloh.netlify.app.
beta-jloh.netlify.app.	13	IN	A	54.206.19.82

;; Query time: 0 msec
;; SERVER: 192.168.0.1#53(192.168.10.2)
;; WHEN: Thu May 28 11:25:05 AEST 2020
;; MSG SIZE  rcvd: 92

Note: This domain was previously setup as a domain on jloh.netlify.app and had SSL provisioned so there is already and existing certificate around for beta.jloh.co and www.beta.jloh.co. I don’t know if this complicates things. I’ve removed the domain from jloh.netlify.app in the hope it somplifies things.

Hey @james,
We can almost provision this branch subdomain certificate. We just need you to add an extra - in your CNAME, between the branch name and your Netlify name. See #2 here for more details:

Let us know when that’s done and we’ll get it provisioned!

Whoops, my bad! Edited the old one and forgot the extra - doing it by hand!

See updated dig below. Sorry for the run around!

$ dig +short beta.jloh.co
beta--jloh.netlify.app.
54.206.19.82

No worries. One day, hopefully we will be able to extend these certs without needing you to include all the little dashes but in the meantime… just renewed your certificate so you should be all set!

Hey @jen! Thanks, I can see the SSL cert is now covering beta.jloh.co but maybe I’m misunderstanding how this is meant to work.

I thought now that beta.jloh.co was set to point to beta--jloh.netlify.app it would show the content from beta--jloh.netlify.app but it still seems to be showing the content from just plain jloh.netlify.app. ie not the beta branch.

Not sure if there is anything else I need to do before it works? beta.jloh.co was an active domain on the jloh netlify app previously and the old SSL cert did cover it, so not sure if this complicates things.

Thanks again for your help so far!

Hey @james,
Hmmm yeah I see what you mean! It looks like you still have beta.jloh.co set as a domain alias for jloh.netlify.app here, which is probably creating DNS confusion somewhere: https://app.netlify.com/sites/jloh/settings/domain#custom-domains

Can you remove that and see if it fixes things?

Thanks so much! It’s all working now.

I noticed the domain was there but didn’t want to touch things in case it broke things further. Hope everyone at Netlify has a wonderful weekend!