Status badge incorrectly shows failing when deploy is auto cancelled

Hi there,

My site is auto deployed when I make an update to my github repo. I found that whenever I make a change to files which don’t impact the content of my website (e.g. updating the repository .readme) the build is triggered, then cancelled because there was no change to the website content.

When that happens the status badge shows as failing, but it’s not failing - it was just automatically cancelled because there was no reason to do the deployment.

Is this a bug, or something that I’m doing incorrectly?

2 Likes

Hi, @MeStrak, and welcome to our Netlify community forum.

I completely agree with you that the badge should still show “Success” not “Failed” because there wasn’t a failure.

This issue is a limitation of the status badges which is that, currently, they treat any most recent build that didn’t complete (or isn’t in progress) as a failure.

I have filed an issue to track this. If/when this issue is resolved we’ll update this community topic to let you know.

Thanks for reporting this and please let us know if there are other questions about this.

4 Likes

Hi, I have the same issue, which become visible with switching to monorepo. Now when you update one app in monorepo, all other apps’ badges show failed build.

Thanks for that additional data point! I’ve added it to the feature request, and this thread is still the right place to follow to learn when the behavior might change (so far it is not planned, but hoping additional reports like yours will help get the work prioritized!)

Yep, I’m in the same situation. In my case, I’m using Sanity Studio and the Netlify Dashboard Widget. If I push a change that doesn’t affect the website it still triggers a website build and when it’s cancelled, it shows as “Failed” on the badge that is shown in the Sanity Studio…which causes confusion with my client.

Great that you all are already aware, hope you get enough interest to move this up in the priority queue.

1 Like

Hi, @dmorda, and welcome to the Netlify community site. :+1:

That another +1 and I updated the issue to reflect that.

Looks like you guys appreciate +1s so I’m throwing my hat in the mix!

Yup, hopefully we’ll eventually win over our product team to prioritize the fix :slight_smile: Thanks for sounding off!

Hi @luke, where is the issue you are referring to? Perhaps a Github issue?

I’m just curious as I’ve been tracking this for a while. I liked your original reply, but I want to make sure my +1 is tracked too!

Hi, @michaelyuen, it is a GitHub issue but the repo is private. I do have your +1 added there and checked that the count there and this issue’s count are in sync (which they are now).

Thanks for the +1. :+1:

1 Like

This is happening to me. Most of the builds in me repo are unrelated to the website, so most show as failed because they are canceled. I can’t use the badge because of this.

1 Like

Thanks @markledwich2, added your +1 :+1:

Same boat here. Was looking to add build status badges to our readme in order to make failing builds more visible. But we have a monorepo where the failed status on cancelled renders them unusable for this purpose.

Wanted to throw my :+1: on there, but I love the monorepo support and pretty much everything y’all do. Keep up the great work!

Thanks, added your voice the feature request!

+1 for me! I’m using the badges with a monorepo.

I also noticed that when a build auto cancels its site thumbnail on the Netlify account “Sites” page also reverts to generic. It would be nice if the previous successful build thumbnail persisted!

Thanks for getting involved, I’ve +1 you to the request.

+1 for me as well. I have several deploys in a monorepro.

1 Like

This issue caused my team to believe deployments were broken. Please fix!

1 Like