SSL Let's Encrypt subdomain issue

Hi there,

I’m currently working on a project where I’ve added a new subdomain and I’m currently having trouble provisioning a new certificate to include the newly added subdomain. Is there any way the current certificate can be updated or be issued a new one?

I can provide the address / subdomain in a direct message as its meant to be semi-private for now. Thanks.

Hi, @timboslice.

You can private message (PM) that to one of our support staff and I’ve confirmed that PMs are enabled for your community login. Note, that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

Hi, @timboslice, before we can proceed please delete the inactive DNS zone at Netlify here:

https://app.netlify.com/account/dns/

Once that is done, then delete the branch subdomain under Site Name > Settings > Domain management > Branch subdomains.

Finally, create the branch subdomain CNAME record as described in this support guide:

Please reply here when that is complete and our support team will extend the SSL certificate to cover this subdomain. If there are any questions about this, please let us know.

Thanks Luke,

We updated the DNS record for the subdomain the same way in the article you sent. I removed the branch subdomain on Netlify, but I wasn’t totally sure if I should set that up again before you extended the SSL certificate. Let me know if I should set that up first.

Thanks!
Tim

All set, Tim! If you have the name set as a primary domain or a domain alias, we’ll get a certificate - but then we don’t serve the branch content :slight_smile:

Now we should, with ssl. Let me know if you have any trouble using, please!