Ssl error bad cert domain

@luke I’m having the same SSL cert issue with https://reactrally.com/

Will you please help me fix this?

Thanks!

Heya - you use cloudflare in front of us on your www:

$ host www.reactrally.com
www.reactrally.com has address 104.27.184.35
www.reactrally.com has address 104.27.185.35
www.reactrally.com has IPv6 address 2606:4700:3033::681b:b923
www.reactrally.com has IPv6 address 2606:4700:3035::681b:b823

…see this article about how to disable then we should be able to get a certificate:

I’ve disabled Cloudfare. Can you please issue a cert for the following sites?

www.reactrally.com

And for each year 2015-2020:

2015.reactrally.com

2020.reactrally.com

It won’t let me post a link for each year :man_shrugging:

Thank you!

You can add all the names in our UI on the domain settings page, and we’ll get a certificate automatically for the additional names :slight_smile:

Hi! I’m having a problem with my website : baptistemenard.com
When people try to access this domain, they get a SSL certificate issue (the certificate name “*.netlify.com” is not matching).

What do I need to do?

Thank you!

Hi @Karzam! Welcome to netlify community.

It looks like your certificate was updated yesterday. I tested your site and I am not getting the issue. Are things working as expected now for your other site visitors?

Hi, i’m havind the same problem in my site semcomp.com.br
i am using cloudflare hostname, and followed steps here in the forum to configure, but apeared this error

Hi, @SS-Cat, and welcome to the Netlify community site. :slight_smile:

There is a community “common issue” topic about this here:

Would you please make the changes discussed there and then try renewing the SSL certificate in the Netlify web UI at “Site Name” > Settings > Domain management > HTTPS?

If that doesn’t resolve the issue, please let us know.

Do I need to add DNS records in Netlify or just add the domain under Domain Management?

Hi @laura or @luke

Could you refresh the certificated on all the sites on my account as well?
Having problem regenerate the sites after redeploy the sites.

mockingbird team and the domains:
dev.mockingbird.bonnierforlagen.se
test.mockingbird.bonnierforlagen.se
mockingbird.bonnierforlagen.se

Thanks in advance!

I don’t know if this is related, but when I look at the HTTP response headers for my app, I get this: “write EPROTO 140051887118144:error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure:…/deps/openssl/openssl/ssl/record/rec_layer_s3.c:1407:SSL alert number 40”

My site is sleepy-boyd-ee8387.netlify.com

…is this possibly related to the recent Let’s Encrypt bug?

Hi @John_Alm_Martensson! Welcome to netlify community.

Looks like the certs for all 3 sites have been automatically refreshed now. :slight_smile:

Hi @alistairfairweather! Welcome to netlify community.

Your certificate is not working due to the way you have your DNS set up. You’ll want to follow the instructions in this post to get that corrected:

Then you should be all good with SSL!

Hi @mzabriskie!

You’ll need both! But you don’t have to add the DNS records to Netlify if you’d rather keep that elsewhere. You will need to follow the directions here in that case: [Common Issue] Can I host my site on Netlify but keep my DNS at my domain registrar?

That did it, thanks Laura. (The actual issue was slightly more complex - CloudFlare was proxying that domain - but your solution prompted the fix so, thanks)

1 Like

Hi!

I have the same issue as many have reported here:

The certificate is only valid for the following names: *.netlify.com, netlify.com 
Error code: SSL_ERROR_BAD_CERT_DOMAIN

Account: rajat404.netlify.com

My domain is rajat404.com
I bought it from somewhere else, though I’ve now directed the nameservers to Netlify’s nameservers.

It seems that the SSL certs need to be updated by someone from the Netlify team. Please do the needful :pray:

Let me know if there is something I can do from my end.

Hi, @rajat404, and welcome to the Netlify community site. :+1: :

The existing SSL certificate only covered the apex/root domain and not the www subdomain.

When this occurs, the solution for this is to click the “Renew certificate” button here to have the additional domain names added:

https://app.netlify.com/sites/rajat404/settings/domain#ssl-tls-certificate

I did click this button and the certificate has been updated now. If there are other questions or concerns, please let us know.

1 Like

@laura Hi, I am having the same issue for www.timingliu.com. Could you fix that for me please? Thanks a lot!!!

Hi Laura. Thanks for refreshing all my certs without me even asking. My sites are working great. Thanks!

Hey @Timing_Liu,

Have you ensured that you’ve followed the advice in this post first?