SSL Certificate Stuck in "Waiting on DNS propagation"

Hello,

I know this has been asked before but for the life of me I cannot figure out the issue.

Admittedly, I did screw up my AWS Route 53 configuration but I fixed it now and DNS has propagated.

SSL is still stuck in “Waiting on DNS propagation”. I can browse to my site, but the https cert is issued to *.netlify.com so it obviously prevents most users from browsing to my https site.

Any idea? Do I just have to wait?

Thanks!


Your connection is not private

Attackers might be trying to steal your information from moneerrifai.com (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_COMMON_NAME_INVALID

Subject: *.netlify.com

Issuer: DigiCert SHA2 Secure Server CA

Expires on: Jul 7, 2020

Current date: Aug 7, 2019

PEM encoded chain:-----BEGIN CERTIFICATE----


Hi, it looks like you already got a certificate in place there. Let me know if you’re still having trouble. Thanks.

I am having the same issue as reported by the OP

but the https cert is issued to *.netlify.com so it obviously prevents most users from browsing to my https site.

Any thoughts?

I actually found this guide that pointed out a second place in Route 53 to update the name servers
https://chathandriehuys.com/blog/posts/aws-domains-and-netlify/

Route 53 -> Registered Domains ->

Once i did that and got confirmation from AWS that it went through, Netlify started redirecting my apex domain to www. and testing HTTPS worked. (also the dashboard started showing Let’s Encrypt info about my new cert).

So all is working now!

yeah for me I did everything mentioned in the documentation but my issue persisted. I ended up deleting the whole site from netlify and re-building it and that was the quickest fix for me. I understand that this might not work for everyone but site is new and has not officially launched but the other suggestions mentioned in this thread should help someone else

Thanks!