SSL certificate need install help

Hello,

I need help to install an SSL certificate for my custom domain, djzaragoza.dev.

Any help is greatly appreciated

To my eyes it looks like you’ve installed a certificate with an invalid CA Chain:

$ curl -v https://www.djzaragoza.dev
*   Trying 104.248.78.24:443...
* TCP_NODELAY set
* Connected to www.djzaragoza.dev (104.248.78.24) port 443 (#0)
* ALPN, offering http/1.1
* SSL certificate problem: Invalid certificate chain
* Closing connection 0
curl: (60) SSL certificate problem: Invalid certificate chain
More details here: https://curl.haxx.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

You’ll need to work with your vendor to get a correct one and reupload it, or let us get one for you.

Would you be able to get one for me? I would really appreciate it.

Thank you!

You can do it yourself :slight_smile:

  1. remove your custom certificate from the domain settings page.
  2. use the “provision let’s encrypt certificate” button in the same page.
  3. wait an hour or two and let us know here if it’s not working and we can go take a look. I took a quick look at your DNS settings and they should work fine for creating a certificate on our system automatically.

I did the following:

  1. Verify DNS config = successful

  2. Clicked on “provision certificate” and clicked again on “provision certificate

  3. Received error message “we could not provision a Let’s Encrypt certificate for your custom domain”

Help?

not sure what that error was about, probably just pushing the button twice :slight_smile:

Regardless, our automated system put the certificate in place before you finished posting this response - at 9:24PM UTC on 27 Jun

Seems to work well for me in the browser - let me know if you don’t see that!

It worked since yesterday. Laura Jodz helped resolve it! Thank you!

1 Like

That’s great to hear, @djzaragoza! :tada: