SSL Cert required for branch deploy subdomains

Hi there, I am not able to provision SSL certs for branch deploys on any site. URLs in question are:
staging.*.tomorrowapp.io
For apps:
admin, checkout, www, script

I have read this needs to be done manually? Could you advise further?

Thanks

Hiya @warrenjday and welcome to our community!

TL;DR the answer to your question depends how you have things configured. In your case, since we host your DNS, you can configure those yourself! To do so:

  1. configure branch deploys for whatever branches you want us to build, here for instance: https://app.netlify.com/sites/tomorrow-website/settings/deploys#deploy-contexts
  2. make a commit to that branch after configuring, leading to a successful deploy of that branch on your site.
  3. click the button on the domain settings page to add a branch subdomain: https://app.netlify.com/sites/tomorrow-website/settings/domain#branch-subdomains , which you’ve done for staging
  4. we’ll update the SSL certificate automatically, as we’ve done on that site (no update was needed based on our current certificate covering the branch subdomain already - *.tomorrowapp.io covers staging.tomorrowapp.io

That is the only naming scheme that we’ll manage automatically - branchname.yourprimarycustomdomain

Hey,

Thanks for the comment. This now works for the domain www but for others the cert is invalid. For example the following URL shows a cert error. I have tried to renew the cert for this app, but with no luck. Can I do anything else to get this working, or is it not possible due to the extra subdomain?

Strange but the cert does work for https://staging.admin.tomorrowapp.io - no idea why :stuck_out_tongue:

https://staging.checkout.tomorrowapp.io/

Yup, there is a bug right now on branch subdomains for subdomains. I’ve just updated the certificate manually to include that name, and future branches on that site should now “just work” - let me know if not!