Some image doesn't show up on gatsby static blog

Hi,

I run a Japanese blog https://1kohei1.com on Netlify. When I made a change this morning and deploy to Netlify, some image didn’t show up. One example of such image is https://1kohei1.com/static/874fde24301ab27ae12e51e2fa8b5fcf/8a209/atcoder-rating.png in the article.

When I locally build and serve, these images show up successfully. So, I believe this has something to do with Netlify.

Once I deploy this morning, this happened. Could somebody give me an advice how to fix them?
Thanks in advance!

@1kohei1 this has something to do with service workers in Gatsby.

When I hit your site with incognito it shows up just fine.

I must have seen your site before your last deploy, because when I went to it today it failed in my main browser. Once I deleted the service worker cache, your site worked fine.

You may want to check with the Gatsby community to see if you have everything setup correctly for the service worker.

Reference: https://www.gatsbyjs.org/docs/resource-handling-and-service-workers/#service-worker-update-handling

Thanks for your help on this @talves! Service workers can be tricky.

Hi @talves,

Thanks for your comment! I will check with Gatsby community!

1 Like