Site deploy still failing after several attempts

Hey friends, I’m really struggling to deploy my site from GitHub. I think the issue is the poverty of my understanding of some aspects of Git. I’ve read through the documentation and done a few Google searches; I keep finding people creating .toml files in their directories, but I am just at a loss after trying a few of those suggestions.

My build command has failed, even after specifying the command in a .toml file in the root directory.
Someone mentioned I shouldn’t use a build command since it’s a static site, but when I do that, I also get similar errors.

What is my problem here?

Netlify site name: 1. reverent-goodall-5a4147

2:48:16 PM: Build ready to start
2:48:18 PM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
2:48:18 PM: build-image tag: v3.3.20
2:48:18 PM: buildbot version: 0ee111aa6b75403f01f5d27b0a6736d30a2da28c
2:48:19 PM: Fetching cached dependencies
2:48:19 PM: Failed to fetch cache, continuing with build
2:48:19 PM: Starting to prepare the repo for build
2:48:19 PM: No cached dependencies found. Cloning fresh repo
2:48:19 PM: git clone https://github.com/UmbrellaProgrammer/Coding-Portfolio
2:48:20 PM: Preparing Git Reference refs/heads/master
2:48:21 PM: Starting build script
2:48:21 PM: Installing dependencies
2:48:21 PM: Python version set to 2.7
2:48:23 PM: v12.18.0 is already installed.
2:48:23 PM: Now using node v12.18.0 (npm v6.14.4)
2:48:23 PM: Started restoring cached build plugins
2:48:23 PM: Finished restoring cached build plugins
2:48:23 PM: Attempting ruby version 2.7.1, read from environment
2:48:25 PM: Using ruby version 2.7.1
2:48:25 PM: Using PHP version 5.6
2:48:25 PM: 5.2 is already installed.
2:48:25 PM: Using Swift version 5.2
2:48:25 PM: Started restoring cached go cache
2:48:25 PM: Finished restoring cached go cache
2:48:25 PM: go version go1.14.4 linux/amd64
2:48:25 PM: go version go1.14.4 linux/amd64
2:48:25 PM: Installing missing commands
2:48:25 PM: Verify run directory
2:48:26 PM: ​
2:48:26 PM: ┌─────────────────────────────┐
2:48:26 PM: │ Netlify Build │
2:48:26 PM: └─────────────────────────────┘
2:48:26 PM: ​
2:48:26 PM: ❯ Version
2:48:26 PM: @netlify/build 3.1.5
2:48:26 PM: ​
2:48:26 PM: ❯ Flags
2:48:26 PM: deployId: 5f2886200b21198bda00aa98
2:48:26 PM: mode: buildbot
2:48:26 PM: timersFile: /tmp/substage_times.txt
2:48:26 PM: ​
2:48:26 PM: ❯ Current directory
2:48:26 PM: /opt/build/repo
2:48:26 PM: ​
2:48:26 PM: ❯ Config file
2:48:26 PM: No config file was defined: using default values.
2:48:26 PM: ​
2:48:26 PM: ❯ Context
2:48:26 PM: production
2:48:26 PM: ​
2:48:26 PM: ┌───────────────────────────────────┐
2:48:26 PM: │ 1. Build command from Netlify app │
2:48:26 PM: └───────────────────────────────────┘
2:48:26 PM: ​
2:48:26 PM: $ build
2:48:26 PM: Installing dependencies
2:48:26 PM: Python version set to 2.7
2:48:27 PM: v12.18.0 is already installed.
2:48:28 PM: Now using node v12.18.0 (npm v6.14.4)
2:48:28 PM: Started restoring cached build plugins
2:48:28 PM: Finished restoring cached build plugins
2:48:28 PM: Attempting ruby version 2.7.1, read from environment
2:48:29 PM: Using ruby version 2.7.1
2:48:30 PM: Using PHP version 5.6
2:48:30 PM: 5.2 is already installed.
2:48:30 PM: Using Swift version 5.2
2:48:30 PM: Started restoring cached go cache
2:48:30 PM: Finished restoring cached go cache
2:48:30 PM: go version go1.14.4 linux/amd64
2:48:30 PM: go version go1.14.4 linux/amd64
2:48:30 PM: Installing missing commands
2:48:30 PM: Verify run directory
2:48:30 PM: /usr/local/bin/build: line 57: : command not found
2:48:30 PM: Caching artifacts
2:48:30 PM: Started saving build plugins
2:48:30 PM: Finished saving build plugins
2:48:30 PM: Started saving pip cache
2:48:30 PM: Finished saving pip cache
2:48:30 PM: Started saving emacs cask dependencies
2:48:30 PM: Finished saving emacs cask dependencies
2:48:30 PM: Started saving maven dependencies
2:48:30 PM: Finished saving maven dependencies
2:48:30 PM: Started saving boot dependencies
2:48:30 PM: Finished saving boot dependencies
2:48:30 PM: Started saving go dependencies
2:48:30 PM: Finished saving go dependencies
2:48:33 PM: ​
2:48:33 PM: ┌─────────────────────────────┐
2:48:33 PM: │ “build.command” failed │
2:48:33 PM: └─────────────────────────────┘
2:48:33 PM: ​
2:48:33 PM: Error message
2:48:33 PM: Command failed with exit code 127: build
2:48:33 PM: ​
2:48:33 PM: Error location
2:48:33 PM: In Build command from Netlify app:
2:48:33 PM: build
2:48:33 PM: ​
2:48:33 PM: Resolved config
2:48:33 PM: build:
2:48:33 PM: command: build
2:48:33 PM: commandOrigin: ui
2:48:33 PM: publish: /opt/build/repo/Coding Portfolio
2:48:33 PM: Caching artifacts
2:48:33 PM: Started saving build plugins
2:48:33 PM: Finished saving build plugins
2:48:33 PM: chmod: cannot access ‘/opt/buildhome/.gimme_cache’: No such file or directory
2:48:33 PM: Error running command: Build script returned non-zero exit code: 1
2:48:33 PM: Failing build: Failed to build site
2:48:33 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
2:48:34 PM: Finished processing build request in 15.258128326s

could you post a screenshot of your build settings as well as your package.json please?

also,

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

Hi perry, thank you for trying to help with this. Here you go.

Aha, thanks for that!

You cannot call your build command “build”. How do you build your site locally? If you literally have a script in the file build - you’ll need to call it something else to use it here. If you don’t need a build command, just leave that field empty and we’ll copy the files instead of running anyting.