Site deploy failed

I need advice to debug deploy https://app.netlify.com/sites/condescending-jackson-2d69ce/deploys/5e33344f49a8d86aa601037c

Hi, @joel743, welcome to our Netlify community site.

This site and deploy no longer exist. Did this site get deleted?

Hey,
Yes sorry about that I ended deleting that site. But I found out what the problem was.

I could not deploy either to netlify. I tried to deploy on Heroku and the error message it gave me helped. I guess netlify needs to know what version of Node.js to download and “node”: “=> 10.13 < 10.11” was not being accepted. I changed the node version from package.json file to the latest node and it finally worked. Can someone explain to me why exactly this worked.

“engines”: {

“node”: “12.14.0”

},

Hi Joel,

Glad it’s working for you now! Unfortunately we can’t set the node runtime directly via the package.json file.

To set the specific version, you need to use one of the NODE_VERSION environment variable, or a .node-version or .nvmrc file. You can find full details about this in our Manage build dependencies documentation.

1 Like