Sign up works but no users

Hello everyone,
I am having a weird issue and I’m not sure if it’s designed that way but here goes:

I want to use Identity for a small website, and have implemented signup and login by following the gotrue-js docs. Both methods seem to work fine, as in, I get no errors and a response that matches my expectation. So, I can sign up and then login with those same credentials just fine.

However, none of the users from my testing are showing up in Identity and when I go to settings, the “Active users” count is still 0/1000.

Is there something I’m missing or shouldn’t those users show up on app.netlify.com -> Identity or at least count towards my 1000 active users quota?

Edit: A few pieces of information upfront:

  • Registration is set to “open”
  • Autoconfirm is turned on
  • I am making the requests from local dev environment

It is quite possible that we only count active users once a day when we do our billing run, Petter. You didn’t mention what site this was so I couldn’t check the settings there to see if time has repaired this or not. Mind telling us which site it’s for? You can use the API ID if you don’t want to tell us the name

Hi @fool,
Thanks for getting back!

The API ID for the project is 6d8a2eb6-21a1-47ae-b8e4-572683c4e571.

Checking it now, I see 1/1000 active user, but I have signed up 4-5 test users.

Edit: I have just tested signing up again and can provide the following:
Endpoint: https://PROJECTNAME.netlify.com/.netlify/identity/signup
Method: POST
Status code: 200 OK

{
  "id":"c9857db6-a744-4d9d-83e7-1b10ac50557a",
  "aud":"REDACTED",
  "role":"",
  "email":"REDACTED",
  "confirmed_at":"2019-08-18T19:15:10.201840372Z",
  "confirmation_sent_at":"2019-08-16T08:49:04Z",
  "app_metadata":{
    "provider":"email"
  },
  "user_metadata":{
    "test":"test-string"
  },
  "created_at":"2019-08-16T08:49:04Z",
  "updated_at":"2019-08-18T19:15:10.202027712Z"
}

Yet, the user does not show up on https://app.netlify.com/sites/nervous-mahavira-38ff6e/identity.

Active users are users who have logged in during this billing cycle, I believe :slight_smile: So just inviting someone doesn’t really make them active.

I have an open email ticket that is similar to this, so from now on I’ll just write here and drop the email correspondence.

So, I think I have figured out part of my issue: I was the using the audience attribute when instantiating the GoTrue auth client as I would like to use multitenancy. Removing that attribute and testing signup again, the user now shows up in Identity.

The question is then where the test users I created with the audience set went?

don’t know - they aren’t in our database is all I can tell. I guess that we didn’t return a sane error when you tried to add them in a way we weren’t expecting. Our JWT expert is out for the next week or so but I’ll revisit this with him when he gets back so we can file a bug to improve that behavior!

Thanks for that @fool. I really want to use Netlify for authentication instead of Firebase, so I’m looking forward to hearing from you!

Hi @PetterDK,

Our hosted Identity service doesn’t support setting a custom audience. It’s supported in the gotrue library we created to allow you to setup multitenancy in your self-hosted identity instance. However, you can’t use it in our hosted Identity service. Can you tell me how you intended to use the audience attribute in your web app? Also note that you can set custom data in the app_metadata that users can’t change, which would allow you to check if a user is part of a specific group. This is also typically what roles are used for.