Redirect on root domain behaves different - Not preserving query params

Hi,
I have my Netlify site setup with a _redirects file according to the documentation:

I’m using the redirects to create short urls for specific pages:
/BTS20 ref=:ref /experiences/berlin-talent-summit?ref=:ref 301
/bts20 ref=:ref /experiences/berlin-talent-summit?ref=:ref 301
/BTS20 /experiences/berlin-talent-summit 301
/bts20 /experiences/berlin-talent-summit 301

As you can see I want the ref parameter to be preserved in the redirect url.

This works perfectly on my test system (with or without trailing slash)
:white_check_mark: https://dev.talentspace.io/BTS20?ref=netlify
:white_check_mark: https://dev.talentspace.io/BTS20/?ref=netlify

But on my root domain the url without trailing slash will not preserve the refparameter:
:x: https://talentspace.io/BTS20?ref=netlify
:white_check_mark: https://talentspace.io/BTS20/?ref=netlify

I can’t see any difference in configuration between the two sites. This seems like a bug to me or some weird behavior because it’s the root domain.

Hey @Wats0n, welcome to the forum :slight_smile:

I clicked your links and they seem to retain the ref param on my end. Here’s what I see when I click the link with the red x next to it:

If that looks right to you, I wonder if doing a hard refresh of the page in your browser will clear the browser cache and pull the new redirect rules. Let me know and if this doesn’t help, we’ll revisit.

Also wanted to share this resource in case it’s helpful:
https://docs.netlify.com/routing/redirects/redirect-options/#query-parameters

Hmm, now it works for me too.
Thank you for taking a look.

Glad to hear. Let me know if you run into the same issue again down the road. For now, closing this out.