Production deploy fails - preview build works. Preview deploys showing in production deploy section

Issues:

  1. Production deploys are failing for the last two days even though build finished successfully.
  2. Preview builds are successful but showing under Production deploy section - screenshot

Latest production deploy logs:

  1. https://app.netlify.com/sites/postwoman/deploys/5eb89d4246588d00068753a7
  2. https://app.netlify.com/sites/postwoman/deploys/5eb8210e89c051a38a3470ca

site name: https://postwoman.netlify.app
custom domain: https://postwoman.io
error message:

Mostly shows no error: log #1

-----------
6:05:01 AM: Post processing done
6:05:25 AM: Finished processing build request in 2m16.645785769s

Often shows this error: log #2

-------
9:15:27 PM: Post processing done
9:15:29 PM: Failing build: Failed to deploy site
9:15:59 PM: Failed to inform the API about a failed build, please retry the build or contact support
9:15:59 PM: Finished processing build request in 2m46.737329527s

Hope deploy logs URL are enough. Attaching screenshots of build settings:

I’ve also encountered a weird error code: custom_domain is owned by another account while adding/updating/saving environment variable. I own the domain, which makes this error code weird. Attaching screenshots of environment variable section’s with error code produced on “save”. Even though, this error is displayed - env variables have been saved successfully - that’s super weird.

screenshots of environment variable section

I asked for support 3 times in a row (sorry for ping - my production build is down), still no response. Hoping response asap. Thanks for this amazing product. Kudus to the whole dev team.

hi there, we just made some changes to how deploys/domains work, can you try again and let us know if you still see this issue?

1 Like

Hi @perry, thanks for the reply.

First of all, sorry for sending those 3 support tickets in a row. Being a dev - I shouldn’t have done that. Anyways build deployments are now fixed.

And don’t push to production on a friday night :wink:

Thanks for the Netlify dev team.
Regards,
Liyas

1 Like

great, glad to hear its working again :fireworks: