Problems migrating my Jekyll site to Netlify

Hello, excuse my ignorance, I am new to this. First of all thank you for reading, I have been trying to migrate a Jekyll template from GitHub to Netlify (this one: https://github.com/andrewbanchich/forty-jekyll-theme), I have forked the repository and created a branch called gh-pages as it said in the README.mid file of the Jekyll theme and when I tried to migrate the site to Netlify I get the following error message:


It says that I must check this link to fix it: https://www.netlify.com/blog/2017/05/11/migrating-your-jekyll-site-to-netlify/?_ga=2.210171734.291449304.1585174600-1357503207.1585174600

I created a file with the name “Gemfile” in the GitHub repo and added the following content, as indicated:

source "https://rubygems.org"
gem 'github-pages'

But the part where it says that I should put the version string in a file called /.ruby-versionis not very clear to me.

It says that after doing this, the site can be connected to Netfily without problems, but that part has not been very clear to me, if it is not a problem, could someone explain this to me step by step please? Thank you so much!

Hi, @MBeaks, and welcome to the Netlify community site. :+1:

The solution is similar. Create a file named .ruby-versions (with the “dot” at the start). That file should contain the version number only: x.y.z, with no trailing newline.

Then commit that file to the git repo and Netlify will use that file to set the Ruby version used during the site build at Netlify.

You can also set the Ruby version with an environment variable at Netlify instead of using this file. There is more about both methods here:

If there are other questions about this, we are happy to answer.