Pretty URLs with the setting turned off

My blog uses Jekyll and has permalinks like so:

permalink: /2020/02/10/adding-text-linting-to-eleventy

When build, this comes out as /2020/02/10/adding-text-linting-to-eleventy.html. I’ve noticed that I can access these URLs w/o the .html setting.

I see Netlify has a setting for this (Pretty URLs) but it is turned off for my site. I don’t have a redirect doing this either. Any idea how this works?

To be clear, I don’t want it to stop. Just curious. :slight_smile:

That’s intended- by default, our service allows you to refer to HTML files by either name (with .html or without). Pretty URLs can help enforce the non-HTML name. Hope this helpful :slight_smile:

1 Like

Thanks. Is this documented?

Hello, yes, it is documented at the bottom of this doc: https://docs.netlify.com/routing/redirects/redirect-options/#trailing-slash