Performance degradation

https://www.netlifystatus.com/

The yesterdays message: “The issue is affecting all US traffic. We are continuing to investigate the issue.” and “Our monitors and our affected network provider’s monitors confirm that all traffic is now flowing correctly again”, but that does not seem to be correct since yesterday I was not able to access most of the websites hosted on Netlify from Zurich, Switzerland. Also triggered one build out of interest and it went for an infinite time until I manually cancelled.

Even today feels like most of Netlify hosted websites are slow. I see response times dropped from usual 20-50ms (from my location) to 200ms-2s :slight_smile:

Please share some status update what’s happening and the estimation on when we could expect usual performance.

Thanks.

hi @nesvarbu, which sites is this regarding?

if at all possible, could you capture a HAR file for us in the sites where you are observing degradation, so we can take a look at the data?

https://toolbox.googleapps.com/apps/har_analyzer/

thanks so much.

Sure, please find it here:
https://filebin.net/npgidxqinm5l526a/13.har

Is there any update on this? The issue still persists. It cannot be higher latency on my side as all other CDNs works as fast as before.

hi nesvarbu, thanks for creating that HAR file. We are still investigating this issue - thanks for your patience.

HI, @nesvarbu. I checked the x-nf-request-id header for slow requests in the file. I’m showing that the HTTP requests originated from Europe but were directed to a CDN node near New York in the U.S.A.

The most common cause of this incorrect DNS lookup is using a DNS server which doesn’t localize the DNS lookups. The most commonly reported DNS server for this issue is 1.1.1.1. People report being directed to New York even when they are are making the request from far away.

Would you please test changing your DNS resolver to 8.8.8.8 and let us know if this improves the issue? 8.8.8.8 is known to resolve correctly while 1.1.1.1 does not.

Hi @luke

It helped on my side, thanks. I am more worrying that other users are experiencing the same then.

Hi, @nesvarbu. I’m also troubled as 1.1.1.1 is quite a popular DNS resolver. We will be contacting the owner of this DNS resolver about this and we’ll let you know what they say.