'Page not found'

Hi,

My netlify site name is : ‘https://bey.netlify.app/

I have deployed the site from gitlab but, when I click on the link above, it displays “Page not found”.

I thought maybe I had an indexing problem because I have several html files and, maybe, netlify can’t find the home page… So, I guess I have to indicate the path but, how can I do…? Regarding the build settings, I have none and I don’t know if I should do have.

I am really a novice and I hope you can help me!
Thank you

@dgillain Does this help?

I had already viewed this post and that’s what made me think I had an indexing problem. I still don’t understand how I can concretely solve my problem.

Download the files for the latest deploy from Netlify and verify that everything is where you expect it to be. My guess is that you have your website files down one level from where they should be. That is, in a subdirectories instead of at the top level.

What’s the name of your build folder?

I have downloaded the files for the latest deploy from Netlify and the content of the folder is the same as the one registered on my computer. However, my .html fields are not stored in a subdirectory but at the top level of my website folder. Is this a problem for Netlify?

Can I create a build folder : from my website folder registered on my computer? or directly from Netlify?

Great suggestion to download the files, @gregraven- that is exactly what I did to dig in here.

@dgillain, it looks like you don’t have a file called “index.html” - that is what we look for to publish. Do you want to try renaming your main page—maybe ProjetDeThese.html?—to be index.html and seeing if you’re able to see a published site then?

My home page is DossierDeLaPhonotheque.html Should I rename it in my folder, the one registered on my computer? Sorry, but I am not yet comfortable with this process…

I have renamed my home page “index” from Gitlab but I still can’t see it from Netlify. Do I forget to do something?

Yes, another thing! Looks like you set a base directory here:
https://app.netlify.com/sites/bey/settings/deploys#build-settings

Try deleting that (it’s for monorepos, which your repo is not) and let’s see how that goes.

I deleted the base directory, but nothing has changed :no_mouth:

Did you deploy again with the new/removed setting? :slight_smile:

@dgillain Your bare site name does not automatically call up random html pages, it looks only for the index.html page. Therefore, the “page not found” message was correct. If you want to display the contents of your website when visitors type in https://bey.netlify.app/, you will have to rename dossierdelaphonotheque.html to index.html.

When you try to visit https://bey.netlify.app/dossierdelaphonotheque.html, the page loads as expected.

I had not correctly redeployed the website, but now the link allows me to display my home page directly!

:joy: Thanks to you two!

1 Like

@dgillain You’re welcome. All you have to do now is get jQuery to load from the location you specify, get your custom scroller to load from the location you specify (and maybe think about changing the name so at least there’s no space in it), and fixing a couple of JavaScript errors in the footer scripts.

I saw on the web console what the malfunctions were. I’m going to work on it!

1 Like

I am having the same issue and netlify is only uploading my .png’s

nevermind i fixed it

1 Like