Page not found when I submit form

Hello Netlify team,

I created a page with html and css which I linked the url to a form such that when I click the submit button in the form it redirects to this page. But it gives the 404 page instead,

When I click on “back to our site” it now takes me to the page I created.
How do I make the page load immediately instead of showing me a 404 page.

Hiya, sorry you are having trouble getting your forms to work.

This Support Guide is the first port of call to debug any forms issues. There are also many other Support Guides for forms - you can find them here: #Netlify-support:support-guides

We also recommend trying to search the forums or look at topics tagged Netlify forms if you haven’t already - it’s likely your question was already asked by someone else!

If you are still having problems, please provide more information such as what you have already tried, and a link to your live form. :slight_smile:

Thank you for reaching out @perry I have my form method as “post”.
Please help explain the second part of the instruction below:

Make sure that you POST your form request (not GET) with a Content-Type of application/x-www-form-urlencoded in most cases. However, if and only if you are submitting the form with a file upload then the Content-Type needs to be multipart/form-data instead.

Hi, @amarealcoder. That section is saying that the content-type to use in your HTTP request headers will depend on if your form includes a file or not. It is also saying to use the POST HTTP action to send the form not the GET HTTP action.

If you have other questions about that section, please let us know what your questions are.

We would be happy to troubleshoot the form itself. Would you please send us a link to where your form appears?

I visited the URL in the screenshot but there is no form there that I can see. If we can test the form we will be able to answer.