Page Not Found After deployment

Greetings, locally i can npm run build my project without any error. When iam trying to publish it on netlify via github it doesnt work. I get a successful notification that my project deployment was sucessfull but when i visit the link it doesn’t work.

Here is my live link in netlify:
https://infallible-shirley-710b9c.netlify.com/

Here is my github repo:

Btw, my project develop is in VueJS and Vuetify .

hmm, do you have a deploy log you can post here?

4:27:15 AM: Build ready to start
4:27:20 AM: build-image version: 9e0f207a27642d0115b1ca97cd5e8cebbe492f63
4:27:20 AM: build-image tag: v3.3.2
4:27:20 AM: buildbot version: ef8d0929ed0baabafd8bbb7d0b021e1fc24180c0
4:27:20 AM: Fetching cached dependencies
4:27:20 AM: Starting to download cache of 113.6MB
4:27:21 AM: Finished downloading cache in 1.071483084s
4:27:21 AM: Starting to extract cache
4:27:25 AM: Finished extracting cache in 3.958211563s
4:27:25 AM: Finished fetching cache in 5.075576632s
4:27:25 AM: Starting to prepare the repo for build
4:27:25 AM: Preparing Git Reference refs/heads/master
4:27:26 AM: Starting build script
4:27:26 AM: Installing dependencies
4:27:26 AM: Started restoring cached node version
4:27:28 AM: Finished restoring cached node version
4:27:29 AM: v10.16.0 is already installed.
4:27:30 AM: Now using node v10.16.0 (npm v6.9.0)
4:27:30 AM: Attempting ruby version 2.6.2, read from environment
4:27:32 AM: Using ruby version 2.6.2
4:27:32 AM: Using PHP version 5.6
4:27:32 AM: Started restoring cached node modules
4:27:32 AM: Finished restoring cached node modules
4:27:35 AM: Started restoring cached go cache
4:27:35 AM: Finished restoring cached go cache
4:27:35 AM: unset GOOS;
4:27:35 AM: unset GOARCH;
4:27:35 AM: export GOROOT=’/opt/buildhome/.gimme/versions/go1.12.linux.amd64’;
4:27:35 AM: export PATH="/opt/buildhome/.gimme/versions/go1.12.linux.amd64/bin:${PATH}";
4:27:35 AM: go version >&2;
4:27:35 AM: export GIMME_ENV=’/opt/buildhome/.gimme/env/go1.12.linux.amd64.env’;
4:27:35 AM: go version go1.12 linux/amd64
4:27:35 AM: Installing missing commands
4:27:35 AM: Verify run directory
4:27:35 AM: Executing user command: npm run build
4:27:36 AM: > play@0.1.0 build /opt/build/repo
4:27:36 AM: > vue-cli-service build
4:27:37 AM: - Building for production…
4:28:05 AM: WARNING Compiled with 2 warnings1:28:05 AM
4:28:05 AM: warning
4:28:05 AM: asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
4:28:05 AM: This can impact web performance.
4:28:05 AM: Assets:
4:28:05 AM: css/chunk-vendors.dd00d5a1.css (319 KiB)
4:28:05 AM: warning
4:28:05 AM: entrypoint size limit: The following entrypoint(s) combined asset size exceeds the recommended limit (244 KiB). This can impact web performance.
4:28:05 AM: Entrypoints:
4:28:05 AM: app (565 KiB)
4:28:05 AM: css/chunk-vendors.dd00d5a1.css
4:28:05 AM: js/chunk-vendors.bff43441.js
4:28:05 AM: css/app.a7814ad9.css
4:28:05 AM: js/app.ecf5f00a.js
4:28:05 AM: File Size Gzipped
4:28:05 AM: dist/js/chunk-vendors.bff43441.js 238.03 KiB 77.05 KiB
4:28:05 AM: dist/js/about.19d41774.js 18.14 KiB 6.73 KiB
4:28:05 AM: dist/js/app.ecf5f00a.js 8.17 KiB 3.29 KiB
4:28:05 AM: dist/css/chunk-vendors.dd00d5a1.css 318.87 KiB 36.10 KiB
4:28:05 AM: dist/css/about.a3554508.css 7.20 KiB 1.58 KiB
4:28:05 AM: dist/css/app.a7814ad9.css 0.06 KiB 0.08 KiB
4:28:05 AM: Images and other types of assets omitted.
4:28:05 AM: DONE Build complete. The dist directory is ready to be deployed.
4:28:05 AM: INFO Check out deployment instructions at https://cli.vuejs.org/guide/deployment.html
4:28:06 AM: Skipping functions preparation step: no functions directory set
4:28:06 AM: Caching artifacts
4:28:06 AM: Started saving node modules
4:28:06 AM: Finished saving node modules
4:28:06 AM: Started saving pip cache
4:28:06 AM: Finished saving pip cache
4:28:06 AM: Started saving emacs cask dependencies
4:28:06 AM: Finished saving emacs cask dependencies
4:28:06 AM: Started saving maven dependencies
4:28:06 AM: Finished saving maven dependencies
4:28:06 AM: Started saving boot dependencies
4:28:06 AM: Finished saving boot dependencies
4:28:06 AM: Started saving go dependencies
4:28:06 AM: Finished saving go dependencies
4:28:06 AM: Build script success
4:28:06 AM: Starting to deploy site from ‘/’
4:28:06 AM: Creating deploy tree
4:28:06 AM: 12 new files to upload
4:28:06 AM: 0 new functions to upload
4:28:07 AM: Starting post processing
4:28:08 AM: Post processing done
4:28:08 AM: Site is live
4:28:27 AM: Finished processing build request in 1m7.138570727s

This article has the best information on debugging that situation:

Let us know if that doesn’t help you get things figured out!

1 Like

Problem solved. The problem was that i didnt select a directory to deploy the site . (So i choose dist) and it work perfectly . Thank you

1 Like

Hi there,
I’m also experiencing issues with the above. I’ve gone through the logs and checked them out and I do believe I see a index.html file. Though it doesn’t have much in it at all. I’ve also checked my build setttings and have the dist folder destination set. I’m doing this with Scully and Angular (new for me with Scully) as I’ve done some work with Gridsome and Netlify before which I’ve had working fine. Not to sure where else to look also, if someone can provide some advice that’ be great.
Kind regards,
Guy

hey @KiMPo, have you tried downloading your site and seeing what gets generated? that might make it easier to check which settings are the right ones for you and whether you have an index file:

Hey @perry ,
That’s what I did try, after it deployed and I noticed it didn’t work, I downloaded the site (what was generated) and I can see the index.html file but I don’t see any of my markup in there at all. It’s like the dist is the wrong directory that I’e set for the build… but I’m not 100% sure why this is as this is how it’s all setup on my local. Would it help if I provided the downloaded log?
Also thanks for getting back to us on this one, greatly appreciated.
Kind regards,
Guy

Hey @KiMPo, could you please share your Netlify URL so we can take a look at your deploy settings and logs? In the meantime, wanted to share an Angular/Scully tutorial that may be helpful for seeing how a successful project is set up:

Heya @jen and @perry,
Greatly appreciate your help, I was able to get it working now. I didn’t have a netlify.toml file so I ended up adding that in with the build scripts and also added the appropriate build shortcuts to package.json and after deploying it looks like it’s working now! So thanks for the information.
Kind regards,
Guy

1 Like