Open graph/twitter previews not working

Could you please help me find why twitter/OG previews are not working for this domain? I have everything implemented and I thought i might have to give some time for domains propagation. Iam afraid thats not the case. Twitter card validator is working fine, but i get no previews while sharing on whatsapp or anywhere else (including twitter). But it works on facebook. Please help. Also its worth noting that the domain name server has recently been transfered from zeit’s now.

URL - https://www.wismim.com

Hey @wisabid,
It looks like you don’t have prerendering enabled for this site. You can toggle it here:
https://app.netlify.com/sites/wismim-online/settings/deploys#prerendering

Here’s a great, in-depth post about our prerendering service:

Please note the first caveat there (though it looks like you already have things set up correctly)!

We cache the prerendered content for 24 to 48 hours, so you will want to make sure to test with different URLs each time if you are making changes and republishing a lot while you get things dialed in. Most importantly, this cache is NOT invalidated by a new deploy of your site!

Want to turn on prerendering and let us know if you still have this issue?

Hello Jen,

Thank you for your response.

I do not have prerendering enabled for https://www.alfalvin.co.uk either. But that one works like a charm and it is built on same stack - Gatsby. Please clarify

Thanks
Abid

Hard to say, as we are not familiar with your code. I’d suggest turning on prerendering as Jen recommended as that is the usual method people use for these things :slight_smile:

Hi there,

Thank you for your response. But please read my message about https://www.alfalvin.co.uk site as that is not configured with pre rendering and it still works.

Thanks
Abid

I saw that. Instead of debugging why a site mysteriously works, though, I’m interested in debugging the site that doesn’t work. Could you please try my suggestion and let me know how it goes?

Hi there,

Thank you for your response. I did try prerendering with a re deployment, but no luck. I thought i already informed.

Thanks
Abid

Hi there,

Have you got any good news for me? I have been waiting for long on this and i do not feel like sharing links without a preview. Please help.

Thanks
Abid

Hi there,

Thank you for your response. I did try prerendering with a re deployment, but no luck. I thought i already informed.

Thanks
Abid

Hi there,

Could you please help me with my issue? Does Scan results for https%3A%2F%2Fwww.wismim.com

[

Scan results for https%3A%2F%2Fwww.wismim.com

These are the scan results for https%3A%2F%2Fwww.wismim.com which scored the grade .

](https://securityheaders.com/?q=https%3A%2F%2Fwww.wismim.com&followRedirects=on)

has got something to do with it as I get a B grade on working site (https://securityheaders.com/?q=https%3A%2F%2Fwww.alfalvin.co.uk&followRedirects=on)

Missing headers for wismim.com are the following :

Looking forward

Thanks
Abid

Hi there,

Have you got any good news for me? I have been waiting for long on this and i do not feel like sharing links without a preview. Please help.

Thanks
Abid

Hi there,

Thank you for your response. I did try prerendering with a re deployment, but no luck. I thought i already informed.

Thanks
Abid

I know you said you “tried it” but you have turned off prerendering again for that site, so our tests are fruitless. Could you please turn it on and leave it on for our testing, and alert me once you’ve done so and redeployed?

Hi there,

Thank you for your response.

I disabled prerendering because my new deployments were not reflecting any new changes in the site. I believe its the default behaviour of prerendering as thats what its meant for - caching.

The good news is I was able to solve preview issue deep diving into the issues & discussions of community. It was due to a style tag presence prior to og tags and I sticked to the work around of positioning it at the right place.

Thank you very much for all your help and support.

Abid

1 Like

thanks for sharing your solution, @wisabid! Glad it is working now :smiley: