Not found on Subdomain

I’ve pointed antonio.laguna.es with a CNAME to my Netlify site and I get a “Not Found”.

Some other person has sites pointed to that domain without further issues. Like “pedro.laguna.es”

What am I doing wrong?

hi there, do you own laguna.es?

Yes, I do. It’s a shared domain between three cousins :joy:

DNS pointing to Route53 and managed from there.

Hi, @ALaguna.

The custom domain must also be added to the site settings under Site Name > Settings > Domain management > Custom domains (which is found here).

Once you do that, the last step is to click the “Verify DNS” button under the HTTPS settings on that page.

If it still doesn’t work after doing this, please let us know.

Hi @luke, can’t seem to do that since my cousin has already added the domain. I would have thought that pointing the CNAME to my app it would just work?

Hi, @ALaguna, the CDN nodes must know which site to show for a specific custom domain. This is why it must be added to the site settings. If that isn’t done, the CDN doesn’t know which of the millions of sites to display.

There is also a limitation that a custom domain can only be used on a single account. If you want to use subdomains of the same custom domain on more than one site, those sites must all be on the same account.

If there are other questions about this, please let us know.

@luke I’m having the same issue.
one of my subdomains - https://login.portadoor.com - which is pointing at a heroku app works.
however https://app.portadoor and https://dashboard.portadoor do not work - theyre both pointing at my heroku app and have their respective DNS settings.

I just get this one the page when i go to either of the links

if i try adding a custom domain it just routes it to my netlify app - which is the root - https://portadoor.com

any ideas?

Hi, @heyjaypray, the issue here is conflicting NETLIFY type DNS records for those same domain names. Those records can be found here:

https://app.netlify.com/account/dns/portadoor.com

There is more about these record types here:

Please read the support guide above for a more detailed explanation.

I’ve unlocked those records for this custom domain now. If you delete the NETLIFY type records for those domain names the other records will begin working.

If this doesn’t work or if there are any questions, please reply here anytime.

@luke Thank you so much! Works great now!