Not able to deploy a React site, fsevents warning

I am facing an issue while deploying the github battle react project to netlify—

This is the error that i am getting–

1:30:38 AM: Build ready to start

1:30:40 AM: build-image version: b0258b965567defc4a2d7e2f2dec2e00c8f73ad6

1:30:40 AM: build-image tag: v3.4.1

1:30:40 AM: buildbot version: 4c73738fafb40608518be6837f4675455e8cfe64

1:30:40 AM: Fetching cached dependencies

1:30:40 AM: Failed to fetch cache, continuing with build

1:30:40 AM: Starting to prepare the repo for build

1:30:41 AM: No cached dependencies found. Cloning fresh repo

1:30:41 AM: git clone https://github.com/arpan-banerjee7/github_battle_react.js

1:30:41 AM: Preparing Git Reference refs/heads/master

1:30:43 AM: Different publish path detected, going to use the one specified in the Netlify configuration file: ‘dist’ versus ‘/dist’ in the Netlify UI

1:30:43 AM: Starting build script

1:30:43 AM: Installing dependencies

1:30:43 AM: Python version set to 2.7

1:30:44 AM: v12.18.0 is already installed.

1:30:45 AM: Now using node v12.18.0 (npm v6.14.4)

1:30:45 AM: Started restoring cached build plugins

1:30:45 AM: Finished restoring cached build plugins

1:30:45 AM: Attempting ruby version 2.7.1, read from environment

1:30:47 AM: Using ruby version 2.7.1

1:30:47 AM: Using PHP version 5.6

1:30:47 AM: 5.2 is already installed.

1:30:47 AM: Using Swift version 5.2

1:30:47 AM: Started restoring cached node modules

1:30:47 AM: Finished restoring cached node modules

1:30:47 AM: Installing NPM modules using NPM version 6.14.4

1:23:47 AM: npm WARN github-battle@1.0.0 No repository field.

1:23:47 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):

1:23:47 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

1:23:47 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchpack-chokidar2/node_modules/fsevents):

1:23:47 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

1:23:47 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules/fsevents):

1:23:47 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})

1:23:47 AM: added 840 packages from 405 contributors and audited 843 packages in 12.899s

1:23:47 AM: 30 packages are looking for funding

1:23:47 AM: run npm fund for details

1:23:47 AM: found 0 vulnerabilities

1:23:47 AM: NPM modules installed

1:23:48 AM: Started restoring cached go cache

1:23:48 AM: Finished restoring cached go cache

1:23:48 AM: go version go1.14.4 linux/amd64

1:23:48 AM: go version go1.14.4 linux/amd64

1:23:48 AM: Installing missing commands

1:23:48 AM: Verify run directory

1:23:49 AM: ​

1:23:49 AM: ┌─────────────────────────────┐

1:23:49 AM: │ Netlify Build │

1:23:49 AM: └─────────────────────────────┘

1:23:49 AM: ​

1:23:49 AM: ❯ Version

1:23:49 AM: @netlify/build 3.1.5

1:23:49 AM: ​

1:23:49 AM: ❯ Flags

1:23:49 AM: deployId: 5f29bcb5eb56b00008da3bdc

1:23:49 AM: mode: buildbot

1:23:49 AM: timersFile: /tmp/substage_times.txt

1:23:49 AM: ​

1:23:49 AM: ❯ Current directory

1:23:49 AM: /opt/build/repo

1:23:49 AM: ​

1:23:49 AM: ❯ Config file

1:23:49 AM: No config file was defined: using default values.

1:23:49 AM: ​

1:23:49 AM: ❯ Context

1:23:49 AM: production

1:23:49 AM: ​

1:23:49 AM: ┌───────────────────────────────────┐

1:23:49 AM: │ 1. Build command from Netlify app │

1:23:49 AM: └───────────────────────────────────┘

1:23:49 AM: ​

1:23:49 AM: $ npm run build

1:23:49 AM: > github-battle@1.0.0 build /opt/build/repo

1:23:49 AM: > SET NODE_ENV=‘production’ && webpack

1:23:49 AM: sh: 1: SET: not found

1:23:49 AM: npm ERR! code ELIFECYCLE

1:23:49 AM: npm ERR! syscall spawn

1:23:49 AM: npm ERR! file sh

1:23:49 AM: npm ERR! errno ENOENT

1:23:49 AM: npm ERR! github-battle@1.0.0 build: SET NODE_ENV='production' && webpack

1:23:49 AM: npm ERR! spawn ENOENT

1:23:49 AM: npm ERR!

1:23:49 AM: npm ERR! Failed at the github-battle@1.0.0 build script.

1:23:49 AM: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

1:23:49 AM: npm ERR! A complete log of this run can be found in:

1:23:49 AM: npm ERR! /opt/buildhome/.npm/_logs/2020-08-04T19_53_49_605Z-debug.log

1:23:49 AM: ​

1:23:49 AM: ┌─────────────────────────────┐

1:23:49 AM: │ “build.command” failed │

1:23:49 AM: └─────────────────────────────┘

1:23:49 AM: ​

1:23:49 AM: Error message

1:23:49 AM: Command failed with exit code 1: npm run build

1:23:49 AM: ​

1:23:49 AM: Error location

1:23:49 AM: In Build command from Netlify app:

1:23:49 AM: npm run build

1:23:49 AM: ​

1:23:49 AM: Resolved config

1:23:49 AM: build:

1:23:49 AM: command: npm run build

1:23:49 AM: commandOrigin: ui

1:23:49 AM: publish: /opt/build/repo/dist

1:23:49 AM: Caching artifacts

1:23:49 AM: Started saving node modules

1:23:49 AM: Finished saving node modules

1:23:49 AM: Started saving build plugins

1:23:49 AM: Finished saving build plugins

1:23:49 AM: Started saving pip cache

1:23:49 AM: Finished saving pip cache

1:23:49 AM: Started saving emacs cask dependencies

1:23:49 AM: Finished saving emacs cask dependencies

1:23:49 AM: Started saving maven dependencies

1:23:49 AM: Finished saving maven dependencies

1:23:49 AM: Started saving boot dependencies

1:23:49 AM: Finished saving boot dependencies

1:23:49 AM: Started saving go dependencies

1:23:49 AM: Finished saving go dependencies

1:23:52 AM: Error running command: Build script returned non-zero exit code: 1

1:23:52 AM: Failing build: Failed to build site

1:23:52 AM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1

1:23:52 AM: Finished processing build request in 24.836070019s

`

github link of my repo-- [Github repo link]

I even downgraded the depedndencies to match with the course, but still no luck.

I have Installed fsevents -->npm i fsevents@latest -f --save-optional
No luck

In local it builds fine. And i am Windows user

hi there,

the warnings are good to make note of, but are not actually the thing that makes the build fail, generally speaking.

The problem exists here:

1:23:49 AM: $ npm run build
1:23:49 AM: > github-battle@1.0.0 build /opt/build/repo
1:23:49 AM: > SET NODE_ENV=‘production’ && webpack
1:23:49 AM: sh: 1: SET: not found
1:23:49 AM: npm ERR! code ELIFECYCLE
1:23:49 AM: npm ERR! syscall spawn
1:23:49 AM: npm ERR! file sh
1:23:49 AM: npm ERR! errno ENOENT
1:23:49 AM: npm ERR! github-battle@1.0.0 build: SET NODE_ENV='production' && webpack
1:23:49 AM: npm ERR! spawn ENOENT
1:23:49 AM: npm ERR!

the command you are trying to run doesn’t seem to be something we like.

Could you post your package.json please?

Also, this Support Guide contains a ton of useful debugging tips that can likely help.

To follow up on this, you definitely wouldn’t want the word SET or the && in your command - try instead removing those, using this instead:

NODE_ENV=production webpack