Non www site claims missing ssl cert despite redirect

Hi,

primary domain is serving content over HTTPS correctly, but if you access the site without www it first serves a “non-https” warning page before redirecting correctly. Any way to mitigate this issue?

If possible please respond via DM.

Cheers!

Hi, @simo, and welcome to the Netlify community site.

We don’t provide private support on our community site, so I didn’t DM for that reason.

In most cases, this issue can be resolved by clicking the “Renew certificate” button found at “Site Name” > Settings > Domain management > HTTPS. You might be able to resolve this using that button.

What site is this for? You can send us the Netlify subdomain or the API ID (not the API key, the ID).

You can DM that information to one of our support staff if you prefer. I’ve confirmed that DMs are enabled for your community login. Note, that only one person can see the DM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

When we reply though, we will do so publicly. (Note: If you upgrade to a Pro level team, there is private technical support available.)

If there are other questions, please include them anytime.

Hi Luke, incidentially I did try the renew certificate option just before posting and it seems to have fixed the issue (at least that’s what I’m assuming fixed it.)

So all good to go. Much appreciated on the support.