No Preview Deploy On Pull Request

I’m trying to follow a tutorial and the video shows that netlify will automatically preview deploy any pull requests. I’ve created the pull request, but netlify is not automatically creating a preview. I’ve tried searching the topic here, but all the questions are for specific or advanced use cases.

Live Deploy: https://jamstack-intro-basic-ds.netlify.com/
Pull Request: https://github.com/codeswish/jamstack-intro-basic/pull/1

I’ve recently attempt closing the above pull request and making a new one, still no preview deploy: https://github.com/codeswish/jamstack-intro-basic/pull/2

Hi, welcome to the Netlify community forum!

Do you have the Netlify App installed to your Github account? https://docs.netlify.com/configure-builds/repo-permissions-linking/#authentication-with-the-netlify-github-app.

I assume you have deploy previews turned on in your Dashboard, but it can’t hurt to check: Settings > Build & deploy > Continuous Deployment > Deploy contexts ,

Hi Tom, thank you for taking the time to help me.

Seems like going through the Continuous Integration setup in the web app got it working. I did it through the command line initially. Maybe I misunderstood, but I thought Netilify would do the preview builds by default?

When you set up a site through the web UI, deploy previews are indeed enabled by default. My guess is that the Netlify App can’t be installed on Github through the command line interface, and therefore the previews are not enabled by default.

Maybe @luke can shed a (somewhat more fact based :sweat_smile:) light on the matter?