Netlify "server not responding"

I’ve posted about this in the community a couple times before, but I did not get a resolution and the issue is still happening.

It used to be that my Netlify sites loaded immediately. Sometimes there could be a slight lag while the CDN was catching up, but generally response was very fast.

For the past few weeks, though, while some of my sites do load quickly, others take several seconds to load, load only after trying a second time, or don’t load at all.

While this is happening, my sites on other servers respond as expected.

It is an intermittent problem so it is difficult to nail down, but I just ran some tests on a Netlify site of mine that was not loading, and I wanted to share the data in case anyone has any ideas.


% date && host gregraven.net

Mon Dec 30 07:55:04 PST 2019
gregraven.net has address 206.189.73.52
gregraven.net has IPv6 address 2604:a880:2:d0::21e9:c001
gregraven.net mail is handled by 20 mx2.improvmx.com.
gregraven.net mail is handled by 10 mx1.improvmx.com.


% curl --output /dev/null https://www.gregraven.net

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:02 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:03 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:04 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:05 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:06 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:07 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:08 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:09 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:10 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:11 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:12 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:13 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:14 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:15 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:16 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:17 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:18 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:19 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:20 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:21 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:22 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:23 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:24 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:25 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:26 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:27 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:28 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:29 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:30 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:31 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:32 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:33 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:34 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:35 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:36 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:37 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:38 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:39 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:40 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:41 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:42 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:43 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:44 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:45 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:46 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:47 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:48 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:49 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:50 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:51 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:52 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:53 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:54 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:55 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:56 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:57 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:58 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:00:59 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:00 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:01 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:02 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:03 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:04 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:05 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:06 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:07 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:08 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:09 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:10 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:11 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:12 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:13 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:14 --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- 0:01:15 --:–:-- 0
dnslookup: 0.014041
connect: 0.000000
appconnect: 0.000000
pretransfer: 0.000000
starttransfer: 0.000000
total: 76.285080
size: 0

0 0 0 0 0 0 0 0 --:–:-- 0:01:16 --:–:-- 0
curl: (7) Failed to connect to www.gregraven.net port 443: Operation timed out


My browser says “the server where this page is located isn’t responding.”

I welcome any help resolving this issue.

Hi Greg,

Thanks for the info. During times when you see this failure, do you also see it happening on other computers or ISP’s? I’m wondering if your getting a cached DNS response.

1 Like

Good question. I would need to set up another computer to test that.

Did anything ever come from that testing, Greg? These incidents don’t usually correspond to an outage on our side and aren’t widely reported, so it does “feel” (super scientific, I know) like something around your network. The IP on that host potentially changes constantly (like, every 20 seconds), so if you have a caching resolver or proxy that doesn’t respect DNS TTL’s or something like that, it would definitely lead to this kind of behavior on a regular basis…

I have tried to provide logs and other data as requested, but I have yet to hear any substantive ideas. Everything used to work, and now it sometimes doesn’t.

oh, sorry, I thought you were volunteering to set up another computer - sorry to have misread. Do you have a mobile phone or other device that can connect?

I did that to a limited extent and post the results – probably in another thread on this. One of the problems is that it seems to be a transient issue, so you can check one moment and the site will not load, and then a minute later it will.

OK, I just spent a fruitless 30 minutes trying different things. I have tried:

  • Main computer using Cloudflare public DNS
  • Main computer using default DNS (192.168.254.254)
  • iPhone (over LTE instead of home Wifi) using Cloudflare
  • iPhone (over LTE instead of home Wifi) using whatever the default is
  • MacBook Pro using OpenDNS, and plugged in to the cable modem instead of the Airport Time Machine

I also turned off VirtualHostX Pro and reverted all my Apache-2 files (which should not have been effecting anything, but still …) to the macOS Catalina defaults on my main computer.

On none of the configurations did all of my Netlify sites load as expected. Usually, a site that did not load on one device would load on another device, but not always. Sometimes, a site that had just loaded on one device would stop responding on that device, and would start responding on another device.

I saw no issues on any device in any configuration with my sites on Digital Ocean, WPEngine, Neocities, Keybase, Surge, GitHub Pages, etc.

Thanks for your help, but I’m giving up. I’ll just live with it until such time if any that it clears itself up as mysteriously as it arrived.

We’ll close this post if you find that this is improved by your update, same as with the others, greg. Do let us know :slight_smile: