Netlify not building - Command failed with exit code 1: npm run build

Hey, I can’t figure out why my app wont build on netlify. I tried building it locally it works, was checking for same file names, lowercase names that are different, tried removing json files and do a clean npm install, none helped. And it’s something related with this project. I’ve tried making a new project that only has App file inside of it and that worked, so it’s something messed up with this up I’m working on.
Here’s a github repo: https://github.com/h3h394/MoviesApp
Here is the picture:

Hi, @h3h394, we released a change today which might be related:

You can test if this is the root cause by changing the build command to the version below which will unset this new CI environment variable:

CI= npm run build

If that doesn’t resolve the issue and/or if there are any questions, please let us know.

6 Likes

O my god, I spent last 4 hours removing every single thing I had and it didn’t work, installing npm again and trying all the solutions on netlify’s forum and stackoverflow. After 4 hours of not working, I’ve tried your solution and that worked the first time. Thank you so muchhhhhhhhhh <3

Same problem and this was also my issue. -_-.
Problem solved using this solution

1 Like

How do you unset CI if using codesandbox?
Nevermind

create a netlify.toml file in the root and use this setting
[build]
command = “CI= npm run build”

1 Like

thank you, i been dealing with problem too!

1 Like

Sorry. I dont understand. I have the same problem. I have to put [build]
command = “CI= npm run build” in netlify.toml? because the issue still persist

Can you explain how you did it?

hi there, please see this thread:

there are some instructions a few posts down from the top :+1:

2 Likes

This works! thank you very much!

2 Likes

Woooooo, thank you so much for this solution!!!

1 Like

thank you so much…

1 Like