Netlify managed DNS issue (possible bug)

Hello folks,

I’m experiencing some serious issue with netlify managed dns; let me explain in details.

I’ve created all my previous DNS records in Netlify DNS including A/AAAA pointing to an old VPS I used before.

After assigning this custom domain to a netlify published site everything worked fine serving it through the auto created netlify A/AAAA records instead the ones entered manually. So far so good…

After I’ve seen that the netlify site is served through Netlify’s own IPs I decided to erase the now useless A/AAAA records pointed to my old vps.

Unfortunately, immediately after deleting the old A / AAAA records site is no longer accessible and dns viewers (dig, drill or dnschecker.org) show no netlify’s A/AAAA records present as before.

Is it some Netlify managed dns bug?
Should I delete and recreate the custom domains from scratch?

Hi, @athan, in order to troubleshoot we need to know which domain is experiencing this issue. Which domain name isn’t working?

You can also send us the site id for the Netlify site where the domain is linked if you don’t want to post the domain name itself.

Sharing the site id will not compromise your site’s security. The site id cannot be used without an API key which has permission for the account (so please don’t post your API key publicly anywhere).

Domain is inray.com

BTW I have now deleted both site and domain and recreated them from scratch without any A/AAAA records this time. It works as it should so please don’t bother with my case.

However I think you should double check the scenario described in my first post. I’ve tried it twice and is a repeatable and easily reproducible issue (bug).

Thanks for being willing to help me luke!

Hi Athan, I’m glad to see you resolved the issue! Migrating over and creating/deleting records should work just fine and we do have people doing this regularly. We’re glad you resolved the issue but without a clear reproduction case or example it’s hard to debug this further.