Netlify Forms bug? I dont know. I am a newbie

Hello Netlify Team

I have this code in a Netlify form:

 Prefered Server Location<br>
 <input type="radio" id="PSL1" name="server" value="Server in USA">
<label for="PSL1">USA</label><br>
<input type="radio" id="PSL2" name="server" value="Server in Europe">
<label for="PSL2">Europe</label><br>

When submitted, the Netlify form submission result shows “USA Server in Europe”

This is weird as it should be “server Server in Europe”
I tested that code at w3school and it gave me the correct result “server=Server in Europe”

Am I missing something here?

Thanks.
Judi

hi Judi, welcome to Netlify. Does this work correctly locally?

hi perry

i can’t test the code locally because i don’t have the backend for forms

this is the original code:

Prefered Server Location<br>
<input type="radio" id="PSL1" name="server" value=" USA">
<label for="PSL1">USA</label><br>
<input type="radio" id="PSL2" name="server" value="Europe">
<label for="PSL2">Europe</label><br>

when i clicked on “USA”, netlify form returned “USA USA”
when i clicked on “Europe”, netlify form returned “USA Europe”
label PSL1 somehow got into the equation

however, i did test the code with w3school and it gave the correct results
when i clicked on “Europe”, w3school returned “server = Europe”
when i clicked on “USA”, w3school returned “server = USA”

to get around this problem, i changed the values into “server in USA” and “server in Europe”
netlify still returns “USA server in USA” and “USA server in Europe” respectively
but at least i know what that means
so it’s not a big deal really

thanks for replying

judi

one more thing - did you see this already?

This Support Guide is the first port of call to debug any forms issues. There are also many other Support Guides for forms - you can find them here: #Netlify-support:support-guides

We also recommend trying to search the forums or look at topics tagged Netlify forms if you haven’t already - it’s likely your question was already asked by someone else!

If you are still having problems, please provide more information such as what you have already tried, and a link to your live form. :slight_smile: