Netlify DNS locks away my subdomain

Hello,

I pointed my registrar to Netlify name servers to serve a SPA Gatsby site I have hosted there. A little while later I added some MX records to a particular subdomain on the site to connect it to my email service provider. But now, this subdomain’s “A” record is completely locked away from me.

When I attempt to add an A record for this subdomain I am told that an A record already exists. In the zones, I see that the A record is being pointed to my Gatsby site. (However it doesn’t actually redirect).

Beside this record is the following disclaimer:

*This is a system record that cannot be managed directly.

I appreciate your immediate assistance

Hi @vershimajr! Welcome to netlify community.

Can you link us to your site please?

Hi laura,

My site is at the URL: https://gigarbox.com

Thank you as well for your lightning fast reply!

To fix I had to purge my entire DNS zone and manually reconfigure…kinda curious why this all had to happen…

I understand now that the source of my issues was me not properly navigating my Account portal. Please see the following sequence of my errors:

  1. I looked to add a subdomain to my site. The first thing I did was go to (Sites -> gigarbox.com -> Domain Settings)
  • This seemed like the logical location for editing my DNS zones
    From here, I saw the option to “Add Domain Alias”, and without proper consideration I clicked the button and added the subdomain.
    (I understand now that this simply created a DNS record which inextricably links that subdomain to my Netlify site. This was not at all obvious.)
  1. I assumed after submitting my subdomain in that “Add Domain Alias” form I would be presented with options to configure DNS records for the domain, but I was not. So I quickly scrambled to find where I could edit the DNS zones.

  2. I found then that the proper route to this page is: (Domains -> gigarbox.com)

At this point, as I mentioned above, my subdomain is now inextricably linked to my Netlify site.

I think this is a big UX problem. It seems to me that there should be only one route for editing DNS settings. (Sites -> gigarbox.com -> Domain Settings) seems to be the most logical route to provide access to DNS records for the domain…unfortunately it only allows you to add aliases to the hosted site.

I think that it should instead provide at least a link to the (Domains -> gigarbox.com) and make it very obvious that this is the place where the user should go to configure DNS settings for the sites domain.

I thank you for considering this input. I really love the services and value you guys add in this ever-changing web world. Would love to see this UX issue addressed

Hi, @vershimajr. We can delete the NETLIFY and NETLIFYv6 type DNS records so you can use those for another purpose besides linking them to a site at Netlify. Please let us know which records to delete and our support team can do so. This will free up those custom domain (or subdomains) for other uses.

Regarding adding DNS records at Domains - “Domain name” for linking to a site at Netlify, this actually doesn’t work. The only way to link a custom domain to a site is “Site Name” > Settings > Domain management > Custom domains. This will automatically create the required NETLIFY/NETLIFYv6 records if Netlify DNS is enabled. (It is required with or without Netlify DNS also.)

If you want to make any other DNS record (not linked to a Netlify site - such as A, TXT, and MX records types), then Domains > “Domain name” is the correct place to add them.

If we can delete any of those NETLIFY/NETLIFYv6 records, please let us know.

Hi Luke, thank you very much for this response. So far I have remedied things by simply purging and correctly manually reconfiguring my DNS Zone.

I guess my concern was that (Sites -> Domain_Name -> Domain Settings) only gives the option to add an alias to the current Netlify site. I would be nice if this page could at least have a button like “Configure DNS Records” which would href us to the (Domains -> Domain-Name) Page.

That would have alleviated my misunderstandings.

Thank you!