Netlify Dev stops as soon as it's connected to localhost

Hey!

I’ve installed netlify-cli and am trying out Netlify Dev, but whenever I run netlify dev, it connects to the localhost for about two seconds then ends the command (and the localhost):

I’m using:

  • netlify-cli @ 2.25.0 (latest)
  • yarn @ 1.21.1 (latest)
  • Google Chrome v79.0.3945.88
  • Windows 10 v2004 (OS 19041.1; 64bit)
1 Like

Hi @timrossback, could you confirm that you were able to successfully complete the steps in our Docs to get things started? It sounds like your project might not be initialized correctly.

Hi @Dennis! I followed those steps but I’m still running into this issue (in a different repo/site that I’ve just started) with netlify dev not running:

Could you please share your netlify.toml that you use to configure netlify dev?

Hey @fool! I might just be new to Netlify and missing something, but when I ran $ netlify init, it didn’t generate a netlify.toml file. It’s only a static site though; would that affect this?

This is the entire site directory (and it works perfectly fine when I deploy it):
image|250

I’m experiencing this same issue. I’ve followed all the setup steps, but to no avail. Have tried with an empty netlify.toml file and my existing one:

[build]
  publish = "dist/"

[context.production.processing]
  skip_processing = false
[context.production.processing.css]
  bundle = true
  minify = true
[context.production.processing.html]
  pretty_urls = true
[context.production.processing.images]
  compress = true

# Redirect default Netlify subdomain to primary domain
[[redirects]]
  from = "https://dev-nicolaos.netlify.com/*"
  to = "https://nicolaos.dev/:splat"
  status = 301
  force = true

thanks for your patience @dev-nicolaos and @timrossback, as we try and figure out what is happening here. We were a bit short staffed over the holidays, but I’ve asked someone from the team that works on Netlify Dev to give some guidance on this. I’m assuming you are still experiencing the issues mentioned above? has anything changed?

Hey @dev-nicolaos, thanks for reporting this issue. We’ve had reports of similar issues because of the update just before the holidays. And fixes for some of these issues have been published already. Can you please try updating your netlify-cli package to latest version via npm i -g netlify-cli@latest. If the issue still persists, please let us know or file a bug at https://github.com/netlify/cli.

1 Like