Netlify Deployment stuck at "Expected — Waiting for status to be reported"

Hi all,

I’m deploying my Hugo based website using Netlify hooked into the site’s Github repo, so every time a new commit comes in, it’ll trigger preview deployment. However, I realized that for the past month, I always stuck at this status netlify/deploy-preview Expected — Waiting for status to be reported"

I know that I can give a workaround by disabling this check from Github side, but I want to know what’s the correct way to solve this? I’ve followed the suggested steps in GitHub Commit Status for "deploy/netlify" doesn't report "successful" but none is working.

Seems like I never got the “success” status from Netlify if that helps.

Ok, it seems that the build and deployment for a branch is OK from Netlify. I can see the preview on my preview deploy url. However, Netlify doesn’t report back to Github, hence the “Waiting for status to be reported”. See screenshot.

Also, reconnecting repo doesn’t work.

Could you let us know which site this is for please, @lunchboxav ? Configuration for these notifications is per-site so it would be useful to examine your specific settings, but you specified no site in your question.

Thanks for letting me know you reconnected the repo - that would have been my first suggestion!

Also please do be aware that OLD PR’s will never get a notification - only new ones - so if you are debugging 4 day or month old ones - that isn’t going to be fixed by anything you do such as reconnecting the repo, so best to tell us the status of a recent one after you reconnected :slight_smile:

Hey, thanks for getting back @fool. The site that I’m working is getenvoy.io. The last PR was 7 days ago. But it was only 2 days when I posted this thread. Should I try reconnect the repo again?