Netlify deploy not synchronizing with what I have on github

Good afternoon everyone, Can someone please help me on that ?

I have my Github repo with my Gatsby CMS in it, I have two different branches, master and develop. To deploy my changes I use netlify that deploys from the master branch. Merges from my develop, I regularly deploy my master branch but it keeps on publishing like nothing happened and stays like my previous commits. Can you tell me where did I mess up with the configuration ?

Second question. I wanted to add “gatsby-source-googlemaps-static”

When I put

      resolve: `gatsby-source-googlemaps-static`,
      options: {
        key: `key`,
        center: `47.330209,-1.5219381`,
              },
          },

in my gatsby-config.js, I get this error when I try to deploy :

6:33:13 PM: error "gatsby-source-googlemaps-static" threw an error while running the sourceNodes lifecycle:
6:33:13 PM: Request failed with status code 403
6:33:13 PM: 
6:33:13 PM: 
6:33:13 PM:   Error: Request failed with status code 403
6:33:13 PM:   
6:33:13 PM:   - createError.js:16 createError
6:33:13 PM:     [repo]/[axios]/lib/core/createError.js:16:15
6:33:13 PM:   
6:33:13 PM:   - settle.js:17 settle
6:33:13 PM:     [repo]/[axios]/lib/core/settle.js:17:12
6:33:13 PM:   
6:33:13 PM:   - http.js:236 IncomingMessage.handleStreamEnd
6:33:13 PM:     [repo]/[axios]/lib/adapters/http.js:236:11
6:33:13 PM:   
6:33:13 PM:   - task_queues.js:84 processTicksAndRejections
6:33:13 PM:     internal/process/task_queues.js:84:21
6:33:13 PM:   
6:33:13 PM: 
6:33:13 PM: not finished source and transform nodes - 0.528s

Which I truly don’t get. Can anybody find out with me about that too ?

Have a nice day/evening you all.

I tried to follow this : https://www.gatsbyjs.com/plugins/gatsby-source-googlemaps-static/

Hi @FCS and welcome to the community!
Can you please share what changes you are expecting to see (link to relevant change in GitHub) and missing from the site (link to place in the site the change should show up)?

For example, a content file:


And result in site;
https://fcs.netlify.app

As for the second question, I recommend asking in:

Hey thanks for answering.

This is what I should have on my master branch (which is pushed) https://imgur.com/a/mePjlNc
When I looked on the deployment it says it deployed the last commit, which should include these changes (compared to what I have here : https://fcs.netlify.app/) What is it that I’m doing wrong ?

Also I’d like to thank you, I’ll ask CCalamos about his plugin.

Thank you

Hey @FCS,
Maybe you’ve resolved this in the last few days? When I go to your Netlify site, what I see is very similar to the image you shared:

That was from this merge commit: https://github.com/Hdz/gatsby-starter-netlify-cms/commit/5c1c1c6632193ffd548f74f05d9c926e20695a03 (where I see that you added ccalmos’ plugin!)

Let us know if you’d like for us to keep looking into this!

Hello Jen, Yes I did thank you ! Auto Publishing was off… I felt totally bad seeing this.

Thanks again.

2 Likes