Netlify CMS /admin not able to confirm email address

Site Details
Site name: https://admiring-saha-d8d745.netlify.app/
GitHub repo: https://github.com/connorocampo/dotdev

Netlify CMS not able to confirm email address.

First, I signed up and then I confirmed my email address. After that, I tried logging in but I get a ‘Email not confirmed’ message.

During set up, I went through all the steps listed here (https://www.netlifycms.org/docs/add-to-your-site/) except importing this:

import CMS from 'netlify-cms'
// Now the registry is available via the CMS object.
CMS.registerPreviewTemplate('my-template', MyTemplate)

Not sure where that should go.

This is my first time trying to add Netlify CMS to my Gatsby site. I’m not very well versed in Gatsby/React either but I’m just sort of experimenting to see if I can hack this together. Any help with how I can fix this would be appreciated.

Edit: Looks like I didn’t add the second widget tag…

<script src="https://identity.netlify.com/v1/netlify-identity-widget.js"></script>

…to my main index file.

There’s another (slightly cleaner) way to fix this, check out this topic:

1 Like

Hey, thanks for the reply. I did see this and am planning to implement this method later this week. It’s been bookmarked :slight_smile:

1 Like

Excellent! If you run into any trouble, don’t hesitate to report back.

1 Like

Hey! So I’m trying to get this working locally before I push it to Git but I can’t seem to be getting it to work.

Here’s what I did:

  1. Comment out Netlify CMS widget scripts in index.html and index.js.

    <script src="https://identity.netlify.com/v1/netlify-identity-widget.js"></script>

  2. Create confirmation, recovery, invitation, and email-change HTML files in my admin folder. Then copy and paste the code from here into their respective files.

  3. Then in Netlify, add the file paths relative to my domain to **Settings > Identity > Emails **.

Like so…

/dotdev/static/admin/invitation.html

…and so on for the rest of the files.

The only step I’m not 100% clear on is " You will have to tell you SSG not to add a layout to these templates (there shouldn’t be any <html> , <head> or <body> tags for these pages)." I assumed this is as simple as omitting these tags and leaving the copied code untouched.

Now, I’m testing it by running gatsby develop and viewing the /admin page locally. Here’s what I see:

Would you be able to point out something I am maybe doing wrong? If it helps, I can push all these changes.

Some static site generators will automatically apply a layout to any html file they come across. If that’s the case, you’ll probably have to tell it to ignore the identity files.

Would you be able to point out something I am maybe doing wrong?

It looks like you removed the identity widget not only on the root of your site, but also at the /admin/ path. You’ll need it there, since you’re sending your email links to the admin page with the email templates.

I added the identity widget script back into /admin/index.html and it works.

Also, I’m running Netlify CMS on Gatsby. After sending myself a recovery email it seems that they don’t automatically apply styles - in case anyone is wondering!

Thank you, Tom!

1 Like