Netlify build can't resolve npm package

I updated the package.json of my gatsby website/project to install the package gatsby-theme-maximeheckel: ^0.1.8.

However, the build now fails with the following message:
8:31:59 PM: [1/4] Resolving packages...8:32:02 PM: error Couldn't find any versions for "gatsby-theme-maximeheckel" that matches "^0.1.8"

  1. this package is published with this exact version
  2. the build used to work with packages up to 0.1.6, I have the same issue with 0.1.7
  3. I can install the package locally without any trouble
  4. This package is public and is a dependency (not devDependency) of my project

I’m not sure how to fix this, as I don’t know if the issue in on your end or on npm/yarn’s end.
I tried to clear the cache and deploy, I keep getting the same result. I even tried to start a new project: no success

Ok, it seems to be working now, but it took Netlify nearly 45min to an hour before my npm package was discoverable at build time. Weird, maybe I just deployed during a bad time? :slight_smile:

Hi @MaximeHeckel, I’d need to see the build but based on what NPM says, it was just published a day ago:

This means it may not have been available at the time you added it to your package.json.

The package was definitely available at the time of the build (I pushed it and only started building like 30 minutes after that). I could pull the package locally without any trouble. The Netlify build instances on the other and failed to resolve the package for an additional 45 minutes.
(This happened for both the 0.1.7 and 0.1.8 version of my package)
As you can see I pushed new versions since then but I haven’t seen this issue on my more recent builds.

hmm, we can’t really see anything - you never linked to any build logs :slight_smile: If you’d like to link us to some we’ll be happy to take a look next week when our office reopens!