Netlify answers slowly on static file access (after deploy?)

Hi @slorber, even on the free tier you can have a high cache hit rate if your site is accessed often. But the only way to increase it further would be to move to one of our custom or enterprise plans and move on to the Enterprise CDN network. That said, you shouldn’t be having TTFB as high as 20 seconds even on our free tier. Once you provide that x-nf-request-id or at least the URL for an asset that took a long time to load, and the date that you saw it, then we can dig further to see what’s happening.

Hi and thanks.

I’ve run some tests and I see some bad TTFB on a few requests, not necessarily after a redeploy.

Example request:
x-nf-request-id: e66ddb89-2360-4940-a71b-2331115c8dfa-108035021

Actually I’ve run some tests with someone that tries to resolve the website using different netlify ips, and one was significantly worse than the others in term of TTFB: 104.198.14.52

According to the DNS doc it’s your loadbalancer.

Can you tell me how using the loadbalancer ip in the DNS config lead to such results? Is this normal? If this makes TTFB 2 to 10x worse when using the loadbalancer, what about documenting better how this choice can significantly impact performances?

Note you can contact me in private if needed to get perf reports with/without the loadbalancer. I’m not able to contact you privately and I can’t post my client’s url on public forums.

lorber.sebastien@gmail.com or @sebastienlorber on Twitter

I’ve also noticed slow TTFB on deploy preview sites
Ip: 167.99.137.12 / 2a03:b0c0:3:e0::1b:1
Request: e8e4ed40-357f-4220-9f6a-0ad73eb74278-5390482

Are deploy preview sites slower that normal production deployments? As far as I understand, they don’t use your loadbalancer ip, so maybe it’s not only a DNS-related problem.

Note that I have a few concurrent requests happening at the same time, can this be related?

I would also like to chime in to state that I’ve just recently set up my site, and I am getting the same problem.

Content served after page-load (such as ajax requests for json or video file loads) stops at pending for up to 20(!) seconds before being served.

If there are any suggestions I would love to try them.

mind sharing a HAR file of such an experience? It can help us understand the problem: https://toolbox.googleapps.com/apps/har_analyzer/

@fool I am having the same issues. A HAR file can be found here:

https://drive.google.com/file/d/1QMVTzuzq_GXD3zNCda12krNosYclt0QI/view?usp=sharing

That har file seems corrupted, @rshea - can’t load it (it is cut off somewhere in the middle). could you try gathering another one for us?

My bad – @fool try this one? https://drive.google.com/file/d/1l4_4ieKXIyf-spOhUsa0RgP0rj9MSNrU/view?usp=sharing

Thanks. I can definitely see what you’re talking about in there, this request taking 12 seconds seems like a big bummer:

image

…but on our side in our internal logs, we show we sent it in 6ms (the “x-nf-request-id” HTTP response header is a unique value that we can correlate to a specific request in our logs, and so I looked it up).

Was your internet generally working well at the time?

Hi,

On my side I didn’t get any news from my last twitter attempt to solve this problem.

On our side, it turns out that putting CloudFlare on top of Netlify does significantly increase the TTFB performances. It is the exact same deployment, with a single toggle switched on CF side to enable the proxy.

Swyx should have given you both DNS domains (with/without cloudflare proxy) and told me you were studying the problem (fool+gerald), but no news for 1 month.

I feel like I gave you everything I can on my side, and can’t do anything more, except maybe paying 500€/month to solve this problem. CloudFlare is actually a way cheaper solution, and it’s what I end up recommending to my customers currently until this problem is solved. Despite Netlify saying CF on top of Netlify is useless, it turns out it’s not for me.

@fool

I was on a wireless connection, so I just ran this on a fiber 1gbps connection:

Still looks like the load time is happening.

@slorber Interesting – I might try this in the mean time despite using Netlify’s DNS with the hopes that Cloudflare doesn’t improve TTFB.

I also experience really slow download times for js files after a redeploy (4.5s for 300KB).

-> https://drive.google.com/open?id=1zJtxEWd5Luev8JMkVgDtG7Xf7o7t-Cq-

Hi there, thank you & other folks for your patience on this thread as we work to understand the underlying issues here. I know its frustrating to experience slow download times and we want to understand & do better.

We have been talking about this internally and are still looking into these issues, and hope to bring them up with relevant folks who work more closely with our infrastructure in the near future. We’ll update this thread here with any information - and if anything changes for any of you please do keep adding your thoughts here.

Not the quick-and-easy outcome we had all been hoping for - but we will keep looking into this.

I noticed that I got 6 seconds to load the HTML when I first created and deployed an app to Netlify. After ± 3 minutes it was lowered to 43ms. Must have been the CDN provisioning.

1 Like

thanks for sharing. We are actively still working on this issue, and will update this thread as soon as we have news to share.

2 Likes

Hi, @leomrav, and welcome to our Netlify community site.

The geographic routing happens when the DNS query for the domain name occurs with Netlify DNS or when the CNAME lookup occurs for the *.netlify.com subdomain when using third-party DNS.

The routing is controlled by the IP address making the DNS lookup. There is no (supported) way to force a Netlify site to use a specific CDN node.

A post was split to a new topic: Slow load time for Gatsby site

Hi Luke,

Any update on this ? I’m facing the same issue right after deploys across multiple sites. Some are React apps, created with CRA others are Gatsby site.

Hi, @florian-zsa, there is an open issue for uncompressed content often having a slow TTFB but all modern browsers request the compress version so this shouldn’t apply for that traffic.

We’ll need more information to see if this is the same issue which is affecting your site or. Would you be willing to send us a HAR file capture of the issue occurring?

If this isn’t possible, would you please send us the x-nf-request-id header for a HTTP response which was slow?

There more information about this header here:

If that header isn’t available for any reason, please send the information it replaces (or as many of these details as possible). Those details are:

  • the complete URL requested
  • the IP address for the system making the request
  • the IP address for the CDN node that responded
  • the day of the request
  • the time of the request
  • the timezone the time is in

Obviously, if you send us the HAR file, all the other details above will be included automatically.

If there are any other questions, please include them at any time as well.