Naked domain NOT redirecting to www


I have a custom domain (from Namecheap) and have set it up to use Netlify’s DNS by adding the 4 nameservers to the Namecheap DNS control panel.

Everything is working apart from the naked domain is not automatically redirecting to the www subdomain. From what I can tell, this is supposed to ‘just work’.

I haven’t changed any of the default DNS records that Netlify sets, and I can see records in there for www and non-www domains.

I have also added IP6 hoping that might help, but with no luck.

Any ideas?



You need to tell Netlify to redirect the root domain to the subdomain, if you havn’t already done so. For the few sites I have with Netlify so far, none of them has redirected automatically without clicking the “Redirect to primary domain” link.

You can do so under “Settings -> Domain Management -> Domains”.

In the Domain Management > Domains section I already have a setting for this.

It looks something like this -
Primary domain
Redirects automatically to primary domain

In the actual DNS records section I have 2 records that look like this - 3600 IN NETLIFY 3600 IN NETLIFY

Not sure what else I can try?

Just to be clear, if I go here in the browser it works:

However if I go here:
I get a “Your connection is not private” error (NET::ERR_CERT_COMMON_NAME_INVALID)

If you go to “Settings -> Domain Management -> HTTPS”. Does it say that the SSL certificate is issued for both the root domain and the subdomain?

Have you tried to ping the root domain, aka, from your computer to see if it might be cached and is still redirecting you to an old IP?

If you visited the domain before changing to Netlify, it is possible that your computer or ISP is caching the old results, and is still pointing you to the wrong server. As in, not Netlify. This is usually solved by itself whenever the TTL expires and DNS refreshes. You can figure out if cache is at work by doing a traceroute and or ping from your computer.

Another simple test is merely visiting the domain from a computer / phone that has never visited the site before. Preferably with an ISP that hasn’t done the same.

@mattbadley I see your site’s SSL certificate was updated by our system about 7 hours ago. Are things as expected now?

Yes - it’s all magically fixed itself now so must have been the SSL cert.

Thanks for all your help!

1 Like