Mixed Content error in admin

Some sections in admin not opening

config example:

folder: "site/content/solutions/"
create: true
identifier_field: code

Js trying to get data from gitlab by using “http” not “https”

Hi Sam,

Not quite enough details there for us to help out. What site are you working on? What is the URL that leads to errors? What settings do you have in place (please share your entire config file or a link to it in GitHub that can be read by everyone)?

Hi, thanks for reply
This is closed project, so i cant share it all.
It develops on gitlab with own domain.

backend:
  name: gitlab
  repo: ##
  auth_type: implicit
  app_id: ##
  api_root: https://gitlab.custom-domain.com/api/v4
  base_url: https://gitlab.custom-domain.com
  auth_endpoint: oauth/authorize
  branch: master

This component is working in admin:

  • name: “pages”
    label: “Страницы”
    files:
    • file: “site/content/_index.md”
      label: “Главная”
      name: “home”
      fields:
      • {label: “Заголовок страницы”, name: title, widget: string}
      • {label: “Описание страницы”, name: description, widget: text}
      • {label: “Описание страницы для Seo”, name: pageDescription, widget: text}
      • {label: Image, name: image, widget: image}
      • label: “Промо на главной”
        name: main_promo
        widget: object
        fields:
        • label: “Картинка”
          name: image
          widget: image
        • label: “Заголовок”
          name: heading
          widget: string
        • label: “Текст”
          name: text
          widget: text
        • label: “Кнопки”
          name: buttons
          widget: list
          fields:
          • label: “Текст кнопки”
            name: text
            widget: text
          • label: “Ссылка”
            name: link
            widget: text
      • label: “Преимущества”
        name: benefits
        widget: list
        required: false
        fields:
        • {label: “Цифра”, name: number, widget: string, required: false}
        • {label: “Постфикс”, name: post, widget: string, required: false}
        • {label: “Текст”, name: text, widget: text, required: false}
      • {label: “Текст о компании”, name: aboutDescription, widget: markdown, required: false}

This not working:

  - name: "projects"
    label: "Проекты"
    folder: "site/content/projects/"
    identifier_field: code
    create: true
    fields:
      - {label: "Название", name: "title", widget: string}
      - {label: "Описание страницы для Seo", name: pageDescription, widget: text}
      - {label: "Сортировка", name: weight, widget: number, required: false}
      - {label: "Код для ссылки", name: "code", widget: string}
      - {label: "Ссылка на сайт", name: "webLink", widget: string, required: false}
      - {label: "Логотип", name: "logo", widget: "image", required: false, headless: true}
      - {label: "Краткое описание", name: "description", widget: text, required: false}
      - {label: "Детальное описание", name: "detailText", widget: markdown, required: false}
      - {label: "Задача", name: "task", widget: markdown, required: false}
      - {label: "Проблема", name: "problem", widget: markdown, required: false}
      - {label: "Решение", name: "solutionText", widget: markdown, required: false}
      - label: "Отзыв"
        name: "review"
        widget: object
        required: false
        fields:
          - {label: "Фио", name: name, widget: string, required: false}
          - {label: "Должность", name: post, widget: string, required: false}
          - {label: "Текст отзыва", name: text, widget: text, required: false}
      - {label: "Год", name: "year", widget: string}
      - {label: "Решения", name: "solutions", widget: "relation", collection: "solutions", multiple: true, required: false, searchFields: ["name"], valueField: "code"}
      - {label: "Отрасли", name: "industries", widget: "relation", collection: "industries", multiple: true, required: false, searchFields: ["name"], valueField: "code"}

Poroblem in scripts is that netlify trying to get not secure content:

Unless you can tell us what site it is so we can try it ourselves, we probably won’t be able to help further. You can give us the site’s API ID (from the general settings page in our UI), that is not sensitive information to share but will help our team find your site so we can examine it in a browser and see what files and redirects were deployed.

If you have a Pro team, we’d be happy to help you privately in the helpdesk.

I am not using netlify.com for managing site params. I installed only netlify cms and configurated gitlab for autodeploy.

Hi Sam, there’s not much we can do here. If you share the actual site then you may be able to get help from the community, otherwise, there isn’t much for us to work with. Note that you can try the slack community for the Netlify-CMS: https://www.netlifycms.org/community/