LFS Image Transformations are not working

Hi,

Long time Netlify user, but new to LFS and Netlify Large Media.

I have a site that I have set up for LFS using the directions at https://docs.netlify.com/large-media/setup/

I meet the requirements and limitations posted at https://docs.netlify.com/large-media/requirements-and-limitations/

I have a folder /media/uploads with two images in it that seem to be registered properly with LFS

[thewellington:~/Sites … lingtonfamily.net/media/uploads] master+ ± git lfs ls-files
64d642c0c5 - media/uploads/img_20111203_093854.jpg
a4909f7a27 - media/uploads/img_20111203_152040.jpg
[thewellington:~/Sites … lingtonfamily.net/media/uploads] master+ ±

I have a URL that seems properly formatted when I view the source of the page that should display one of the images:

https://www.wellingtonfamily.net/media/uploads/img_20111203_152040.jpg?nf_resize=fit&w=100&h=100

The page that views the image is at https://www.wellingtonfamily.net/victoria/2020-03-18-new-post-with-lfs/

yet image transformation do not seem to be working. I cannot convince this image that it should be any dimension other than it’s original dimensions.

I have checked that the Netlify build has Asset Optimization turned off.

I have checked the versions of the software I am running:

[thewellington:~] % node --version
v13.11.0
[thewellington:~] % netlify --version
netlify-cli/2.40.0 darwin-x64 node-v13.11.0
[thewellington:~] % git --version
git version 2.21.0 (Apple Git-122.2)
[thewellington:~] % git lfs --version
git-lfs/2.10.0 (GitHub; darwin amd64; go 1.13.6)
[thewellington:~] %

The repository is stored at GitHub

I have read through the following posts, following a couple of suggestions, but nothing worked
https://community.netlify.com/t/transform-images-not-working-create-react-app/4336/2

https://community.netlify.com/t/cannot-get-large-media-to-work/4575

https://community.netlify.com/t/file-extension-seems-to-matter-when-using-the-image-transformation-service/8578

Is there anything else you need to know?

Thanks in advance for the help.

Bill

Hi, @thewellington, and welcome to the Netlify community site. :+1:

I’m not seeing this site using Large Media at this time:

https://app.netlify.com/sites/wellingtonfamily/large-media

The add-on doesn’t show enabled at the link above. What happens when you run the following command in the repo where Large Media is enabled?

netlify lm:info

For example, this is what I see in one of my Large Media site’s repos:

$ netlify lm:info
  ✔ Checking Git version [2.23.0]
  ✔ Checking Git LFS version [2.8.0]
  ✔ Checking Git LFS filters
  ✔ Checking Netlify's Git Credentials version [0.1.8]
[thewellington:~/Sites/wellingtonfamily.net] master+ ± netlify lm:info
  ✔ Checking Git version [Git-122.2)]
  ✔ Checking Git LFS version [2.10.0]
  ✔ Checking Git LFS filters
  ✔ Checking Netlify's Git Credentials version [0.1.8]
[thewellington:~/Sites/wellingtonfamily.net] master+ ±

Well that all looks good to me. We will need more information (which could contain sensitive details).

Because of this, we have sent you an email to the email address associated with your Netlify account, and we’ll communicate with you through that email to continue resolving this issue. (Please note that for security reasons, we will not contact you at email addresses not listed in your Netlify account.)

Also, please let us know with a reply here if you don’t receive a message from us.