Large Media add on Disable

I need someone to clear out my large media addon, would love to have a button to trigger this as well!

site name: graydon

I have all files backed up locally.

Hi, @graydonpleasants, the Large Media add-on has been removed. Would you please test a new deploy and let us know if it is successful or not?

Thanks @luke , I had removed my images and .lfsconfig, ran a build on Netlify, then re-enabled lfs to try and recreate the fix mentioned here (as i mistakenly committed and pushed the files with Tower using an outdated LFS:

uploaded 1 image (images/buick.png), and it brought back my entire Large media collection, still not supporting transformations at all. is there a user facing purge button planned?
What other steps can I take? This feature has some real user stumbling blocks but the promise is awesome!

Hi, @graydonpleasants, we can remove the Large Media add-on again. Please note, if you are going to use another Git LFS service (like GitHub LFS), you should not enable Large Media. Large Media and GitHub LFS are both Git LFS services.

By definition, two Git LFS services cannot co-exist on the same repo. <— Note, this could be a “lie”.

I’m by no means a leading world expert concerning Git LFS. When I say it could be a lie, I mean it might be possible to use different Git LFS services on different branches. (Or not - the point is I don’t know.) Please understand that I’m assuming your not doing anything like that and I’m therefore not trying to troubleshoot that in any way. (If you are though, just let us know.)

I think what we need to do is disable Large Media for this site again (which I have already done). Next, delete the .lfsconfig file from the repo. Then, if you are using Git LFS and a different (anything but Large Media) Git LFS service, enable the environment variables mentioned here and quoted below:

  • GIT_LFS_ENABLED : Undefined by default. If set, we’ll use git lfs clone to check out your repository — otherwise we just use git clone .
  • GIT_LFS_FETCH_INCLUDE : If GIT_LFS_ENABLED is set, this specifies by file extension which Git LFS files will be downloaded when cloning your repository. Any other file extensions will have only text pointer files downloaded instead of the original media files. The default file extensions are determined by the site build-image.

Note: If you are not using another Git LFS service (no Git LFS at all for the repo), then don’t add these environment variables.

If you are using them, the environment variables must be added in the site settings in web app and not the netlify.toml file. (We need the options when we clone the repo and we don’t read the TOML file until after the clone is complete.)

If this still doesn’t work, please let us know.

These directions are a bit unclear to me, I am not using any other LFS provider, what else should I do other that delete the image and the .lfsconfig file like I did last time and try and upload again? My goal is to use only Netlify LFS and have my images transformed with the service, but I can’t image the same steps will end up with a different result, can you clean out that library so all my old images dont come back?

Seems like i was able to refresh at least some of the images but some still have the wrong content type/ not being able to transform a few images:


in the thread I initially linked, @marcus ran a script to convert the existing images’s content types so waisting images could be transformed, could we do that here?

Hi, @graydonpleasants, I’ve asked our developers to check if this is the same issue as last time and to apply the same solution if it is.

Also, it might be possible to self-serve this fix in the future by deleting the site and making a new site linked to the same repo. This might force a new Large Media instance to be created which will be “fresh” (for lack of a better word).

Would you be willing to test deleting and recreating the site while we are waiting for the developers to look at this? (If so, and if this doesn’t fix it, please send us the site name for the new site.)

If not (and probably either way), we’ll see what the developers have to say.

Hi, @graydonpleasants, it looks like you recreated the site and resolved this that way.

If this comes up again I’ve been introduced to the “context type correction script” and will likely be able to assist directly next time.